summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-15 10:04:09 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-15 10:04:09 +0100
commitc80eb07d8941868c52e727f04b0a3209b267439a (patch)
tree6d21c7dc948b625d45c39d5360a59405552f6689 /dev-python/pelican-minify
parentdev-python/mido: Bump to 1.3.1 (diff)
downloadgentoo-c80eb07d8941868c52e727f04b0a3209b267439a.tar.gz
gentoo-c80eb07d8941868c52e727f04b0a3209b267439a.tar.bz2
gentoo-c80eb07d8941868c52e727f04b0a3209b267439a.zip
dev-python/pelican-minify: Fix building against hatchling-1.19.0+
Closes: https://bugs.gentoo.org/919905 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pelican-minify')
-rw-r--r--dev-python/pelican-minify/files/pelican-minify-2.0.0-hatchling.patch24
-rw-r--r--dev-python/pelican-minify/pelican-minify-2.0.0.ebuild5
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pelican-minify/files/pelican-minify-2.0.0-hatchling.patch b/dev-python/pelican-minify/files/pelican-minify-2.0.0-hatchling.patch
new file mode 100644
index 000000000000..96de2470e68e
--- /dev/null
+++ b/dev-python/pelican-minify/files/pelican-minify-2.0.0-hatchling.patch
@@ -0,0 +1,24 @@
+From 222b4c97f75f5dc426419bc1ffa45f8015af2e64 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Fri, 15 Dec 2023 10:01:22 +0100
+Subject: [PATCH] Fix install with hatchling >= 1.19.0
+
+Explicitly specify the top-level package name in order to fix installing
+with hatchling >= 1.19.0. These new versions default to installing
+packages that match the project name only, and fail if one cannot
+be found.
+---
+ pyproject.toml | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 98926f2..ef390de 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -110,3 +110,6 @@ known-first-party = ["pelican"]
+ [build-system]
+ requires = ["hatchling"]
+ build-backend = "hatchling.build"
++
++[tool.hatch.build.targets.wheel]
++packages = ["pelican"]
diff --git a/dev-python/pelican-minify/pelican-minify-2.0.0.ebuild b/dev-python/pelican-minify/pelican-minify-2.0.0.ebuild
index aa8e838e3ccd..ea05ba957fdf 100644
--- a/dev-python/pelican-minify/pelican-minify-2.0.0.ebuild
+++ b/dev-python/pelican-minify/pelican-minify-2.0.0.ebuild
@@ -24,3 +24,8 @@ RDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/pelican-plugins/minify/pull/3
+ "${FILESDIR}/${P}-hatchling.patch"
+)