summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 18:50:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 19:50:59 +0200
commit6548d01cf3e6bd8110f596ae6e7c6e361603f6a0 (patch)
tree5e9a9bf35e50a2818b61024d17def7799320f2fd /dev-python/pendulum
parentdev-python/nbval: Enable py3.12 (diff)
downloadgentoo-6548d01cf3e6bd8110f596ae6e7c6e361603f6a0.tar.gz
gentoo-6548d01cf3e6bd8110f596ae6e7c6e361603f6a0.tar.bz2
gentoo-6548d01cf3e6bd8110f596ae6e7c6e361603f6a0.zip
dev-python/pendulum: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pendulum')
-rw-r--r--dev-python/pendulum/pendulum-2.1.2-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/pendulum/pendulum-2.1.2-r2.ebuild b/dev-python/pendulum/pendulum-2.1.2-r2.ebuild
index 92ab23647da8..dcc1239b8504 100644
--- a/dev-python/pendulum/pendulum-2.1.2-r2.ebuild
+++ b/dev-python/pendulum/pendulum-2.1.2-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=7
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -39,4 +39,10 @@ BDEPEND="
)
"
+EPYTEST_DESELECT=(
+ # sigh
+ tests/datetime/test_behavior.py::test_proper_dst
+ tests/tz/test_timezone.py::test_dst
+)
+
distutils_enable_tests pytest