summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-14 05:14:01 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-14 05:33:59 +0100
commit796494c2284cf7d2b0e889c6b224aae1bbb69048 (patch)
treea17aac9217d9c7ec5caa2bf957f80590f95e27e2 /dev-python/pikepdf
parentdev-python/sqlglot: add 19.4.0 (diff)
downloadgentoo-796494c2284cf7d2b0e889c6b224aae1bbb69048.tar.gz
gentoo-796494c2284cf7d2b0e889c6b224aae1bbb69048.tar.bz2
gentoo-796494c2284cf7d2b0e889c6b224aae1bbb69048.zip
dev-python/pikepdf: Bump to 8.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pikepdf')
-rw-r--r--dev-python/pikepdf/Manifest1
-rw-r--r--dev-python/pikepdf/pikepdf-8.7.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pikepdf/Manifest b/dev-python/pikepdf/Manifest
index 9d73692efdba..d2afe56b915a 100644
--- a/dev-python/pikepdf/Manifest
+++ b/dev-python/pikepdf/Manifest
@@ -4,3 +4,4 @@ DIST pikepdf-8.5.2.tar.gz 2854729 BLAKE2B 276d96d21e0d5d581777762572865607718964
DIST pikepdf-8.5.3.tar.gz 2854900 BLAKE2B 6dfd458b96b60cbd2cbd5491353c98710bec458b11f92b8e5abdad05a83567f98e0c21eeafd47650de0d6600f958417d92f62d76034db6663555fc76d8c4714b SHA512 dd7c6d131f1bf61c0cb285c06629c44a5e8436fa368832aacac7d5fcd8ab3b19b96d0d1005b02dd5084a1d9a4200f3fb27f66b60e9625f3cd9bfb32a649f497c
DIST pikepdf-8.6.0.tar.gz 2855625 BLAKE2B f9f0867b72e531c54bd65e0ce74eeea3b5379b04c073863b1e690e989f9d05061635eadb10ca0bb6f79f64e3d16d619b7c1200a35dfbfc8808831960c889e474 SHA512 d272b7f8c334a7c803594a6d7ace2d53a971da0ec1e814d16f20564af5075dbff35e1e28e129dcc2168d1c9b83047a9ea1905b163b24d14179cbd2dc874f84d7
DIST pikepdf-8.7.0.tar.gz 2860417 BLAKE2B bc11b2f1e2023cd25103e78522429cd50a6deae4e598653f6b9e35c82ac2069403c0fd8d17e56597c7189b207dd41dc8ecf23a940095625e19c453695e0290df SHA512 445c6cbd1b311ebfc96924cb5f381fe05ab549826029a796d7b744b93265880b27fe17e9f9cba212c5ed289a5fe6efa5e6457d0912f0ca13109c345d40e20ec7
+DIST pikepdf-8.7.1.tar.gz 2860480 BLAKE2B fa06667947d0166e8597e4fa757ffa96eb69ed3fe2dfd4a54e515678f55afd15a0e2dfcd571fabc933423f0696725d623b0fb9f95cb8ca8633a6581a7957c25d SHA512 3adc075244eb66e0aa4b18882c2ede598b26a40c56497628a8262f82c8ec72af25b4c97ded0771a8e0ec7bb1e7537ec4e172505fd30271a995491361bf17277f
diff --git a/dev-python/pikepdf/pikepdf-8.7.1.ebuild b/dev-python/pikepdf/pikepdf-8.7.1.ebuild
new file mode 100644
index 000000000000..3d641f21ec2c
--- /dev/null
+++ b/dev-python/pikepdf/pikepdf-8.7.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python library to work with pdf files based on qpdf"
+HOMEPAGE="
+ https://github.com/pikepdf/pikepdf/
+ https://pypi.org/project/pikepdf/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# Check QPDF_MIN_VERSION in pyproject.toml on bumps, as well as
+# https://qpdf.readthedocs.io/en/stable/release-notes.html.
+DEPEND="
+ >=app-text/qpdf-11.5.0:0=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/deprecated[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pillow-10.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-6.36[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.21.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-5.0.0[${PYTHON_USEDEP},jpeg,lcms,tiff]
+ >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile to system load
+ tests/test_image_access.py::test_random_image
+)
+
+src_prepare() {
+ sed -e '/-n auto/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}