summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Calligeros <jcalligeros99@gmail.com>2024-06-29 16:39:40 +1000
committerSam James <sam@gentoo.org>2024-06-29 09:25:52 +0100
commita8eb973f55d83f88dbf22124a5e30b75ec547899 (patch)
treed8d6e6fe16f2d5973b48bc0f230e6b0afc0985a8 /dev-python/pillow
parentapp-misc/fastfetch: Stabilize 2.14.0 amd64, #935127 (diff)
downloadgentoo-a8eb973f55d83f88dbf22124a5e30b75ec547899.tar.gz
gentoo-a8eb973f55d83f88dbf22124a5e30b75ec547899.tar.bz2
gentoo-a8eb973f55d83f88dbf22124a5e30b75ec547899.zip
dev-python/pillow: fix build with USE="-truetype"
Build fails if USE="-truetype" due to implied flags conflicing with the vendor_{raqm,fribidi} = False flags. Guard them behind a usex so that they are only enabled if USE="truetype" Closes: https://bugs.gentoo.org/935124 Signed-off-by: James Calligeros <jcalligeros99@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37345 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/pillow-10.3.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/pillow/pillow-10.3.0.ebuild b/dev-python/pillow/pillow-10.3.0.ebuild
index cb13d5f02390..c1d84827dc09 100644
--- a/dev-python/pillow/pillow-10.3.0.ebuild
+++ b/dev-python/pillow/pillow-10.3.0.ebuild
@@ -82,8 +82,8 @@ python_configure_all() {
[build_ext]
debug = True
disable_platform_guessing = True
- vendor_raqm = False
- vendor_fribidi = False
+ $(usex truetype "vendor_raqm = False" "") # BUG 935124
+ $(usex truetype "vendor_fribidi = False" "") # ditto
$(usepil truetype)_freetype = True
$(usepil jpeg)_jpeg = True
$(usepil jpeg2k)_jpeg2000 = True