summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-08 04:37:34 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-08 04:47:32 +0200
commit235031ee40ac236d686454096018332eabc73f65 (patch)
tree585c2dea8bca52fd0b8483b31003b028b94591ff /dev-python/pipdeptree
parentdev-python/virtualenv: Bump to 20.26.4 (diff)
downloadgentoo-235031ee40ac236d686454096018332eabc73f65.tar.gz
gentoo-235031ee40ac236d686454096018332eabc73f65.tar.bz2
gentoo-235031ee40ac236d686454096018332eabc73f65.zip
dev-python/pipdeptree: Bump to 2.23.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pipdeptree')
-rw-r--r--dev-python/pipdeptree/Manifest1
-rw-r--r--dev-python/pipdeptree/pipdeptree-2.23.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pipdeptree/Manifest b/dev-python/pipdeptree/Manifest
index 17f6956620cf..ae24d0d4ee6c 100644
--- a/dev-python/pipdeptree/Manifest
+++ b/dev-python/pipdeptree/Manifest
@@ -3,3 +3,4 @@ DIST pipdeptree-2.21.0.tar.gz 39119 BLAKE2B 15f37f997b89477a9e1815a2bf120ce5251e
DIST pipdeptree-2.22.0.tar.gz 39555 BLAKE2B 6aae7c6a22176dbfcc5184086c37b0237629f48702e1e2484457a6b3eca9442732279c85c3d806cff14edbbea9180d0ed3005c9744780016ee9949a0b530e3aa SHA512 9775d19cc353eae79e6fbe779471998a8368a932f380f34587950a6f4ef62d9185e77764c12cd122029c8690931a5a5939d57a9b1801db9556708676096c2efe
DIST pipdeptree-2.23.0.tar.gz 39737 BLAKE2B 79fe45880f2942b2ded1d16e2767c4005aca52e0768a5723f37f764c7a60a8104a237ffe2a559f631bf760310143814b0e4afbaf1e5f3ef927828036c320da43 SHA512 9c5fdf7c6d3e519357d4aeb40f4aa2807dfec8fb387114cf40d99469becc68c5042af09f2cdebcca868dd78f3a3c1602b349dfe6cb581758c5c73efc3f6e52c6
DIST pipdeptree-2.23.1.tar.gz 39883 BLAKE2B 63b578cc466871dda284f66bacc7e262b18157e5fb98e3a884c5e3eddd6945ad3d41a95e2e24fc23d0917e902f0e9ead152259d5ddc919e77e2940c2e2933119 SHA512 bc62c9cf6ee01bb8167477a21c70a7dd4ae1141c1c0690a1e95aea49cd4cb7d7e18bf076a532b00b79014a23c069df8aa09ac1bfd2d328b57e444192f1b10e5d
+DIST pipdeptree-2.23.3.tar.gz 39804 BLAKE2B deabb55937cca02bad8040c6625cbe2e1688af9fa349d7e74923d73c484022818a28074921d5811f0d8e9189184185829ea4dc4e3004ed5456fcc9ed340de2f5 SHA512 26b5d08a24e297d6f30f3a479ae7f93a71b12cf4bc5ae25ff907f96bf7bef8e5403654b359d79e81aed79fec7961e2b8c4db984e5222f677a33839a125e59343
diff --git a/dev-python/pipdeptree/pipdeptree-2.23.3.ebuild b/dev-python/pipdeptree/pipdeptree-2.23.3.ebuild
new file mode 100644
index 000000000000..108d23b345f5
--- /dev/null
+++ b/dev-python/pipdeptree/pipdeptree-2.23.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="Utility for displaying installed packages in a dependency tree"
+HOMEPAGE="
+ https://github.com/tox-dev/pipdeptree/
+ https://pypi.org/project/pipdeptree/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ >=dev-python/pip-23.1.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ >=dev-python/pytest-console-scripts-1.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # upstream lower bounds are meaningless
+ sed -i -e 's:>=[0-9.]*::' pyproject.toml || die
+
+ find -name '*.py' -exec \
+ sed -i -e 's:pip[.]_vendor[.]::' {} + || die
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock -p console-scripts
+}
+
+pkg_postinst() {
+ optfeature \
+ "visualising the dependency graph with --graph-output" \
+ dev-python/graphviz
+}