summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2020-07-25 22:03:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-27 15:11:54 +0200
commit8113213f81724259198f353b27839a155f5211ad (patch)
tree22f614f8b29225bb43059dde675b8a78f0e3af9c /dev-python/pipenv
parentdev-python/rospkg: bump to 1.2.8 (diff)
downloadgentoo-8113213f81724259198f353b27839a155f5211ad.tar.gz
gentoo-8113213f81724259198f353b27839a155f5211ad.tar.bz2
gentoo-8113213f81724259198f353b27839a155f5211ad.zip
dev-python/pipenv: bump version to 2020.6.2
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pipenv')
-rw-r--r--dev-python/pipenv/Manifest1
-rw-r--r--dev-python/pipenv/pipenv-2020.6.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pipenv/Manifest b/dev-python/pipenv/Manifest
index 6f446f94a2e2..7cdbe4293463 100644
--- a/dev-python/pipenv/Manifest
+++ b/dev-python/pipenv/Manifest
@@ -1 +1,2 @@
DIST pipenv-2020.4.1_beta1.tar.gz 11331009 BLAKE2B 55ac81238b885bdf0293199ca1caf44a78f3cdbec75c9df259411b949dec8b385161e7ef46160ca099ef51041410d8c5d1274ad200eba5c2a9d06c8a5f61c5f1 SHA512 a5de90ae9910a30666ac7323ccf83b78ee11d8993aef1a2108a44f4256d365d0c1abfff72c83748ef82215914931090c670a10eeb511cb48483762b54c80e5c7
+DIST pipenv-2020.6.2.tar.gz 11571734 BLAKE2B bc50535f215b11d284eeec546722a144cfdfeeab6abab8eae51c727c054865f274ac970dc61c23cce7db19ac28a77e44a84453743ba2dc75068feb3a47a19190 SHA512 671765b9e77a18039668eb500989de45c8bd4f15948ee914eb241985098562ebd382168a535a449ac5d216f07327b6787eb8f828b5a6499ef6e77fe5a036441e
diff --git a/dev-python/pipenv/pipenv-2020.6.2.ebuild b/dev-python/pipenv/pipenv-2020.6.2.ebuild
new file mode 100644
index 000000000000..fe8ed6a61e7e
--- /dev/null
+++ b/dev-python/pipenv/pipenv-2020.6.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_beta/b}
+DESCRIPTION="Python Development Workflow for Humans"
+HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
+SRC_URI="https://github.com/pypa/pipenv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/pip-18.0[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-clone-0.2.5[${PYTHON_USEDEP}]
+ "
+
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ <dev-python/pytest-5[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of PyYAML that is backported to Python2
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/patched/yaml2/" || die
+ eapply_user
+}
+
+python_test() {
+ pytest -m "not cli and not needs_internet" -vv tests/unit || die
+}