summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-23 06:56:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-23 07:35:44 +0200
commitd92c5d721f40b6529ccf5f4a0a7286d81dd7ef19 (patch)
tree166c82ffdebe16413602afb2c141e4d2aa8d43ce /dev-python/platformdirs
parentapp-admin/awscli: Bump to 1.27.159 (diff)
downloadgentoo-d92c5d721f40b6529ccf5f4a0a7286d81dd7ef19.tar.gz
gentoo-d92c5d721f40b6529ccf5f4a0a7286d81dd7ef19.tar.bz2
gentoo-d92c5d721f40b6529ccf5f4a0a7286d81dd7ef19.zip
dev-python/platformdirs: Bump to 3.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-3.8.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index 9e59a510634c..63125dfde14b 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -3,3 +3,4 @@ DIST platformdirs-3.5.2.tar.gz 17775 BLAKE2B 2ec36d1efb77cdf5d247dd7e3a731389f41
DIST platformdirs-3.5.3.tar.gz 17780 BLAKE2B bffcc38623022f24175d1cb7097e65f73208b5aefedba2a22a584ea63fafeafe9ec7fd3701f903890282bca33dfd03d11c3070327f7efe474eb64ed548448ac6 SHA512 2510f7e5a260df6ac5d111e80a513979060f7a77c038b79d6db4b42d196ffb8bbacb2db6e986186926931bb28fec867404ed4e23eb3268b6abdbf318d79baa69
DIST platformdirs-3.6.0.tar.gz 18187 BLAKE2B 22e6da0d01e3862518052eba5a20efca4bb365619a6acdbd7722367b5acc4724a06f3baa8a57e8ba2d1957d9be35fd0074db89cc5732596e05bd44c2b5248a41 SHA512 f760e0fec11ca040e2138fc6c8423f9a39106fdf1f41811a19598892fbda31dc75cdeb4138e6355d87bbeeb879fd42ac2eee6e337e6093e59150ee26e73e4d41
DIST platformdirs-3.7.0.tar.gz 18322 BLAKE2B dc1d68c0149e29d043373904616d9d82aea12b62da639cd2daf1d2134b28338200bfd44bdd1750d8ff0202608e92764023dbd9f899f4602d074e246fd3eb10ab SHA512 a7c392787f7db55393888fc5a5e2b7ace131a3ed09d063169630a5cd86f0a9ec5569b2b5de599d2844f3bad439b6a36deb61cbc209faa0913c30c0803ad48ac2
+DIST platformdirs-3.8.0.tar.gz 18451 BLAKE2B cac717c3968fd20b7bdac464443cedcdc50b04b732ae8a212fcb946170ad1553ffae82cbdca05c2cf01ebbc4383216cd0f0afe84cddc2ce6107f10fd40213542 SHA512 64937f3e9e03a9ec8dc2068777dfe553ec09cef62ce53a753608bd9a73e0afaa4489c98046e7b4b3fdbded237cf2813bfd306a6d5ad5788031b6857d8d4fa430
diff --git a/dev-python/platformdirs/platformdirs-3.8.0.ebuild b/dev-python/platformdirs/platformdirs-3.8.0.ebuild
new file mode 100644
index 000000000000..70e821d796fb
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-3.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "hatchling' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "${PN}"
+ version = "${PV}"
+ description = 'A small Python package for determining appropriate platform-specific dirs, e.g. a "user data dir".'
+ EOF
+ # sigh
+ cat > src/platformdirs/version.py <<-EOF || die
+ __version__ = version = '${PV}'
+ __version_tuple__ = version_tuple = (${PV//./, })
+ EOF
+}