summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-27 17:48:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-27 17:59:48 +0200
commit48ff721687d074bf8c25faa15a781e01f6d324fd (patch)
tree457ccebaeed01ff5510c5646771aa4d0c037fb8e /dev-python/pluggy
parentdev-python/pystache: Bump to 0.6.5 (diff)
downloadgentoo-48ff721687d074bf8c25faa15a781e01f6d324fd.tar.gz
gentoo-48ff721687d074bf8c25faa15a781e01f6d324fd.tar.bz2
gentoo-48ff721687d074bf8c25faa15a781e01f6d324fd.zip
dev-python/pluggy: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pluggy')
-rw-r--r--dev-python/pluggy/Manifest1
-rw-r--r--dev-python/pluggy/pluggy-1.3.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pluggy/Manifest b/dev-python/pluggy/Manifest
index 0fc0ab7f2bc1..1df39936022b 100644
--- a/dev-python/pluggy/Manifest
+++ b/dev-python/pluggy/Manifest
@@ -1 +1,2 @@
DIST pluggy-1.2.0.tar.gz 61613 BLAKE2B f1c9d7ca593cd3eaae2f035c8e2d2da09b179991a134e0c0be17642940a853194124b638e208c32b7f8e5250d30d138f4bb79cb414573c0103e6b5024f52abc9 SHA512 b2b6a80737c06e1507eb12513ed7f5ce508fd4a139c559a3a15d9f173f4455ef3847783efb91c32eca6e26cbe37b0336467d50c5db0563d8dbd17bd825cd7407
+DIST pluggy-1.3.0.tar.gz 63670 BLAKE2B afa28641ec0a93e97fed2a03655c76077d046b05f49c4e584df3486dd007fb20296f61b001664d8cbb50d4400f1132f75d5de932caa1d3f92e349f78158d7ade SHA512 d4dbb449f533649da161d7e49f82da5800dabdace4f7aa239c412290470612a45a3ba3c50cafd7bd9ed26cb3aa14648bfa3ed3f41fc0db9ae9399fd7f5933d5f
diff --git a/dev-python/pluggy/pluggy-1.3.0.ebuild b/dev-python/pluggy/pluggy-1.3.0.ebuild
new file mode 100644
index 000000000000..dd354f8f296d
--- /dev/null
+++ b/dev-python/pluggy/pluggy-1.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Plugin and hook calling mechanisms for Python"
+HOMEPAGE="
+ https://pluggy.readthedocs.io/
+ https://github.com/pytest-dev/pluggy/
+ https://pypi.org/project/pluggy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest