summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-10 03:51:58 +0000
committerSam James <sam@gentoo.org>2021-06-10 03:54:47 +0000
commitf9ef8519523f30aa1c12f48723dd355ff4399337 (patch)
tree82b6e2c1d43a5f8880329d66b9b926217ecbdfdf /dev-python/podcastparser
parentmedia-sound/gpodder: add 3.10.20 (diff)
downloadgentoo-f9ef8519523f30aa1c12f48723dd355ff4399337.tar.gz
gentoo-f9ef8519523f30aa1c12f48723dd355ff4399337.tar.bz2
gentoo-f9ef8519523f30aa1c12f48723dd355ff4399337.zip
dev-python/podcastparser: add 0.6.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/podcastparser')
-rw-r--r--dev-python/podcastparser/Manifest1
-rw-r--r--dev-python/podcastparser/metadata.xml1
-rw-r--r--dev-python/podcastparser/podcastparser-0.6.6.ebuild19
3 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/podcastparser/Manifest b/dev-python/podcastparser/Manifest
index b275207085ab..74166542207e 100644
--- a/dev-python/podcastparser/Manifest
+++ b/dev-python/podcastparser/Manifest
@@ -1 +1,2 @@
DIST podcastparser-0.6.5.tar.gz 22232 BLAKE2B 1fcf115954e3394aede643ef28ea7eb13c2969ad3125f82dcfefbb457d61f768247d07d3150fe8adc7aeceb9bb9f0026a2e55f42b3f2a6da76b977528ebd013d SHA512 770d2376eb7d029dc033f46f55d00e02b8040c72c670338ad52ecf065ec4ffd291c6e2ec02cf9b038f8608c7c549808ff14f95017f508bb1526bb79b413e136a
+DIST podcastparser-0.6.6.tar.gz 23482 BLAKE2B 3bdfefe0eafb7d89dfc0063b0fd61c1f5634e381ec6cba634cd9b054dc51476cd0c37267fc40db317ee3d192ea52b4da18e8efc387ad81c6edac25caf7c94147 SHA512 aee6cb72157242afe9f4d9bd201b9538051cce1fc6a153a03206ad041fbff7c99b69659ee4a9c8cbf5583c1a027a9d171943882cb3a48e4ff7f84602cccf2d74
diff --git a/dev-python/podcastparser/metadata.xml b/dev-python/podcastparser/metadata.xml
index 9330487cd7fb..76bd6abc1ae2 100644
--- a/dev-python/podcastparser/metadata.xml
+++ b/dev-python/podcastparser/metadata.xml
@@ -5,6 +5,7 @@
<email>sound@gentoo.org</email>
<name>Gentoo Sound project</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">podcastparser</remote-id>
</upstream>
diff --git a/dev-python/podcastparser/podcastparser-0.6.6.ebuild b/dev-python/podcastparser/podcastparser-0.6.6.ebuild
new file mode 100644
index 000000000000..66dbeee8186b
--- /dev/null
+++ b/dev-python/podcastparser/podcastparser-0.6.6.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Podcast parser for the gpodder client"
+HOMEPAGE="https://github.com/gpodder/podcastparser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest