summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-29 09:05:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-29 09:09:59 +0300
commit44b4bdfbdede1086fc66a9ed545d2c8a9681b16f (patch)
tree2b23d503240b52f4665a65c9964831fb63cc7514 /dev-python/prettytable
parentdev-lang/python: Add keywords to 3.12.0_alpha1 (diff)
downloadgentoo-44b4bdfbdede1086fc66a9ed545d2c8a9681b16f.tar.gz
gentoo-44b4bdfbdede1086fc66a9ed545d2c8a9681b16f.tar.bz2
gentoo-44b4bdfbdede1086fc66a9ed545d2c8a9681b16f.zip
dev-python/prettytable: add 3.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-3.5.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index 4cbe21ce94bf..38f6edd33ab0 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,2 +1,3 @@
DIST prettytable-3.3.0.tar.gz 54305 BLAKE2B 4d131c16b6c6a0fd64aae1f9f54e286bf27b562888af56a6944d192a24c05d6138c3bdb8f298dcc060db7609d72b8d86ab9664bf6bcf43cd2105bdd433bae3cf SHA512 e190717e2ea89e8faddc7015fd5118e0d93ac5f5318641ce5960b22b4ea3740ff12c4d15812b33655252f258c96f9e848f554d1e678d39761c28025ba7772609
DIST prettytable-3.4.1.tar.gz 54395 BLAKE2B 155948a3142e5caca82e6986b51693f63a4230faf7f760b4b9738b653928cc4017835e71f5bf06c1f485b1c579c7517de1fff1424d83dd6ff629981a1d4b85ed SHA512 47a00d5d3bd6be77734abf0c6a50ac13f3d6fb72d8cc7bd2d760c860401f46ee94f766063eaeb30cf3d67c6f33fca9e3a1ae9d68af61139704bb1e23ba649ce4
+DIST prettytable-3.5.0.gh.tar.gz 45387 BLAKE2B 0ddb2c89e80c8f713c01afd4db7d5fcfa8151bcfaf7dcf07d66898b1b868ca093931829fe1b4db96c120a6eda1f84580726931dbd6d49b9870c1fc1eb0e479b9 SHA512 24ef28a42365568bf68a974afd42fcc1bfb9208e1cb75fc1b2890bc2253487afa6536e778b58e320e952ca8bf9b69193bd1293bb7615628d03765ee24c44edff
diff --git a/dev-python/prettytable/prettytable-3.5.0.ebuild b/dev-python/prettytable/prettytable-3.5.0.ebuild
new file mode 100644
index 000000000000..6abe81d3e775
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/
+"
+SRC_URI="
+ https://github.com/jazzband/prettytable/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}