summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-13 06:19:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-13 06:44:52 +0200
commit8c38bea95ff6b6b9071a0cb53de6da208cdda3bd (patch)
treeeca8b6ec20647458d7af3ef9e2a967db70ead8c5 /dev-python/prettytable
parentdev-python/makefun: Bump to 1.15.4 (diff)
downloadgentoo-8c38bea95ff6b6b9071a0cb53de6da208cdda3bd.tar.gz
gentoo-8c38bea95ff6b6b9071a0cb53de6da208cdda3bd.tar.bz2
gentoo-8c38bea95ff6b6b9071a0cb53de6da208cdda3bd.zip
dev-python/prettytable: Bump to 3.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-3.10.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index cac51cb568bf..2471b737dffa 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,2 +1,3 @@
DIST prettytable-3.10.0.tar.gz 54830 BLAKE2B d19abefd31ebf25fd0c5ed91ce1314cebff1c519393fd0d07f82661393c46d337b6589094922f0500180265dc6515706d0d24b5127406a646f83608bed824ccb SHA512 184ab33f3ebe12b3496ff6e2dd2115b4c5f1cf51cedbb73dfa8028e371847c30e69830bb656a92ae3784e70414c4e5782a45b5b39fed87924adaf40078049059
+DIST prettytable-3.10.2.tar.gz 56415 BLAKE2B 0deb8132124f9c19ecaeea46749dda834c758378163646e16e0553b75ad6842b44fe5904ba181d6a2b0c3a822f23cd569977a8168d9245b2e9f08ed16da0089e SHA512 6a71f7d7b6fddca75e4b1bfd96ca6e26301c0c231be4703fe9c59e1c13a1482f814fbbfd661d1fc6bb37346f55a7488b794d5041016faf68711297a8cbdbe5c5
DIST prettytable-3.9.0.tar.gz 47874 BLAKE2B 67d7eb13626d75372947a7662331dc8f4766f74c752ce918c4431cba5f974c5556c5e00566cccdb9e8715829778f3bd53b72ed124f0e19805ffb05f33ea1e219 SHA512 708094e4af6f34a631e63ea4a5655c366b8fd5c0802076d92cb8029402be86b2d528e6d866e8d865790c3d2597229b0f080deac5e843d60e19c326aa909e9eaf
diff --git a/dev-python/prettytable/prettytable-3.10.2.ebuild b/dev-python/prettytable/prettytable-3.10.2.ebuild
new file mode 100644
index 000000000000..21f867b499ce
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.10.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest