summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-20 07:25:06 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-20 07:38:32 +0200
commit2bcd91f33d5d5b3d03d802279397de5245ed8652 (patch)
tree3b974a5e406f1963bbfbc4d3e0bf204fe34080b6 /dev-python/pycairo/pycairo-1.24.0.ebuild
parentdev-python/ypy-websocket: Bump to 0.11.1 (diff)
downloadgentoo-2bcd91f33d5d5b3d03d802279397de5245ed8652.tar.gz
gentoo-2bcd91f33d5d5b3d03d802279397de5245ed8652.tar.bz2
gentoo-2bcd91f33d5d5b3d03d802279397de5245ed8652.zip
dev-python/pycairo: Bump to 1.24.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycairo/pycairo-1.24.0.ebuild')
-rw-r--r--dev-python/pycairo/pycairo-1.24.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pycairo/pycairo-1.24.0.ebuild b/dev-python/pycairo/pycairo-1.24.0.ebuild
new file mode 100644
index 000000000000..bd565080043a
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.24.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="
+ https://www.cairographics.org/pycairo/
+ https://github.com/pygobject/pycairo/
+ https://pypi.org/project/pycairo/
+"
+SRC_URI="
+ https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=x11-libs/cairo-1.15.10[svg(+)]
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ esetup.py build_tests
+ epytest
+}
+
+python_install() {
+ distutils-r1_python_install \
+ install_pkgconfig --pkgconfigdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}