summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-07 17:31:16 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-07 17:31:16 +0100
commit78e5d8a52663403731dc0f819c3d53bc64f7d405 (patch)
treebb38aa3863554e4e0ad3e6b53643622a1fdaac1c /dev-python/pycdio
parentdev-python/pycurl-requests: Add remote-ids (diff)
downloadgentoo-78e5d8a52663403731dc0f819c3d53bc64f7d405.tar.gz
gentoo-78e5d8a52663403731dc0f819c3d53bc64f7d405.tar.bz2
gentoo-78e5d8a52663403731dc0f819c3d53bc64f7d405.zip
dev-python/pycdio: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycdio')
-rw-r--r--dev-python/pycdio/pycdio-2.1.1-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/pycdio/pycdio-2.1.1-r1.ebuild b/dev-python/pycdio/pycdio-2.1.1-r1.ebuild
index 3555b2842eb3..48f92c3847e4 100644
--- a/dev-python/pycdio/pycdio-2.1.1-r1.ebuild
+++ b/dev-python/pycdio/pycdio-2.1.1-r1.ebuild
@@ -5,13 +5,14 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
HOMEPAGE="
https://savannah.gnu.org/projects/libcdio/
+ https://github.com/rocky/pycdio/
https://pypi.org/project/pycdio/
"
@@ -38,6 +39,8 @@ python_prepare_all() {
-e "s:^sys.path.insert.*::" \
-e "s:\.\./data:./data:g" \
example/*.py || die
+ # https://github.com/rocky/pycdio/pull/5
+ sed -i -e 's:assertEquals:assertEqual:' test/test-*.py || die
distutils-r1_python_prepare_all
}