summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-07 04:47:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-07 05:15:07 +0200
commit36cf0ff06dfb534e727fa8c206ee413ae73f18e9 (patch)
tree75c9e7645685d0b4e47d94f9375b23e5383cf063 /dev-python/pydantic
parentdev-python/sentry-sdk: Bump to 1.27.1 (diff)
downloadgentoo-36cf0ff06dfb534e727fa8c206ee413ae73f18e9.tar.gz
gentoo-36cf0ff06dfb534e727fa8c206ee413ae73f18e9.tar.bz2
gentoo-36cf0ff06dfb534e727fa8c206ee413ae73f18e9.zip
dev-python/pydantic: Enable py3.12 on 2.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pydantic')
-rw-r--r--dev-python/pydantic/pydantic-2.0.2.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/pydantic/pydantic-2.0.2.ebuild b/dev-python/pydantic/pydantic-2.0.2.ebuild
index 8603e0f0b172..834053de9dc8 100644
--- a/dev-python/pydantic/pydantic-2.0.2.ebuild
+++ b/dev-python/pydantic/pydantic-2.0.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -40,6 +40,17 @@ python_test() {
# require pytest-examples
tests/test_docs.py
)
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/test_abc.py::test_model_subclassing_abstract_base_classes_without_implementation_raises_exception
+ tests/test_computed_fields.py::test_abstractmethod_missing
+ tests/test_edge_cases.py::test_abstractmethod_missing_for_all_decorators
+ tests/test_generics.py::test_partial_specification_name
+ tests/test_model_signature.py::test_annotated_field
+ )
+ ;;
+ esac
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest -p pytest_mock