summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-01 04:17:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-01 05:17:03 +0200
commit13ce2d5e3f71a262bb197d3100236552a562e131 (patch)
treecd9d2e8f665289b876104a90f75d0e6259eb5173 /dev-python/pylint
parentdev-python/mkdocs-material: Bump to 9.5.34 (diff)
downloadgentoo-13ce2d5e3f71a262bb197d3100236552a562e131.tar.gz
gentoo-13ce2d5e3f71a262bb197d3100236552a562e131.tar.bz2
gentoo-13ce2d5e3f71a262bb197d3100236552a562e131.zip
dev-python/pylint: Bump to 3.2.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-3.2.7.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 24d15a7c8f7e..9f93d8a3a528 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1 +1,2 @@
DIST pylint-3.2.6.gh.tar.gz 1447684 BLAKE2B 22ec600b327b405dfdd7a9ffe94b20faeed6cca92dbfff8e96baa6bebe5c049b90da55f16e84e53d4a22fdbcb5a8caf7719038935522235ccf3364fe2492c16c SHA512 ba7e87f3eaca088b88cec35ae8d1dbd15ec2167a615638b1fe7c1abb711d54742e5fb2d2c9c2836294c464b98ec32d53efaf5afb170d4cb73dacf966dddca62c
+DIST pylint-3.2.7.gh.tar.gz 1448329 BLAKE2B 4ec4a0e2a886e7acc4694582e7f7902b6806750a12286986533a4e57c68eeac96bec43bb4cef2de6ec0a7811cde5ec2cc03226b2213d1b2107aafe73db03c32d SHA512 66dbf0f05aa7aac59f43cab6a1f23c29a3a37d9a19f2c54af0e0aa6f2630fc74d7602a6b6a250e1e02a24723d0513c54a7ee704026af16c8acc50b843708fd98
diff --git a/dev-python/pylint/pylint-3.2.7.ebuild b/dev-python/pylint/pylint-3.2.7.ebuild
new file mode 100644
index 000000000000..0cd2ec935a5d
--- /dev/null
+++ b/dev-python/pylint/pylint-3.2.7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_P=${P/_beta/b}
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/pylint-dev/pylint/
+"
+SRC_URI="
+ https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/astroid-3.3[${PYTHON_USEDEP}]
+ >=dev-python/astroid-3.2.4[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ ' 'python*' )
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[recursion_error_3159]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ 'tests/test_functional.py::test_functional[use_yield_from]'
+ 'tests/test_functional.py::test_functional[wrong_import_order]'
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+
+ if ! has_version "dev-python/GitPython[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/profile/test_profile_against_externals.py
+ tests/testutils/_primer/test_package_to_lint.py
+ tests/testutils/_primer/test_primer.py
+ )
+ fi
+
+ rm -rf pylint || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p timeout
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}