summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-22 20:44:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-22 21:14:39 +0200
commit2b45f082357d3d59d23c858e742a205a965f977a (patch)
tree6d77632088a2d0d273ebc7c2283c1b41bbde3f87 /dev-python/pylint
parentdev-python/charset-normalizer: Bump to 3.3.1 (diff)
downloadgentoo-2b45f082357d3d59d23c858e742a205a965f977a.tar.gz
gentoo-2b45f082357d3d59d23c858e742a205a965f977a.tar.bz2
gentoo-2b45f082357d3d59d23c858e742a205a965f977a.zip
dev-python/pylint: Bump to 3.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-3.0.2.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index aa65242cad0c..801cb50c3f5e 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -4,3 +4,4 @@ DIST pylint-2.17.7.gh.tar.gz 1415651 BLAKE2B 9b2edea7d7d9e05fd265749cb1e50e77513
DIST pylint-3.0.0.gh.tar.gz 1418878 BLAKE2B e0e86bc53e3b081b92a1f7af94a53b125e4d57c08c269e30defd51fcf07024deaf02a664d05d506a469999e6f6660a4f3d26a6698f8023f48a9d81467dce0282 SHA512 77f20425d03fd2e13e3c6ee7f75b32f37918aafbaeab7280d4275e4bdd285d9d4df541e6165bbe76a57663ff78dc4d8126a72788ee29b08fea5c479f9b162b09
DIST pylint-3.0.0b0.gh.tar.gz 1421208 BLAKE2B e58859e85b5001236a7f92060bca3e828957c8a24b3f0981cac795f0a0ce1af3d0be3ab8cc45c9e7fee173f988598e23fb3b9bc3c257d2e354c7d1c621ae7301 SHA512 265f29d28879c09320a8aa3d235873d96505a2472fb9b41ac0f11fa453c2e4d3fb57133bc588583ac82bdaad895b1cafe828f5662d3700baf6eaf6c3f22817db
DIST pylint-3.0.1.gh.tar.gz 1419203 BLAKE2B 6a1c3db074c39a6cd838b39db13650192eb08b95210b95a78e518f9a2cf6c22b92c691f52c6fc08fff5363b12f028897d512f92de7fafabcbdfaeb18ae5535f9 SHA512 c8eca77f70a794e9dc764a70107afdd684a873ab00d6f51d400b96f6e06a39db014a27ef0505f2f7a370e5457e5061c78d2aab4fe1bf59746db4bbe3ae102423
+DIST pylint-3.0.2.gh.tar.gz 1420866 BLAKE2B 2679810940ee5b4a4dcde5a4a3d70052901d6ca8dfd025708fdfe3fadffc7713d3507eaea9a67a2fc0748478e8b6e2c2e66e487bf93749fcd9fea7d070197b16 SHA512 923fab3681aa266aa633cc122cd2076dc73588191ed116da0e83d9d0cff253c93634dd420d32b5ea780c25a8e9ff526d8393d4eae2e046a2ff82df3f5f9322a4
diff --git a/dev-python/pylint/pylint-3.0.2.ebuild b/dev-python/pylint/pylint-3.0.2.ebuild
new file mode 100644
index 000000000000..e01f0325a0dd
--- /dev/null
+++ b/dev-python/pylint/pylint-3.0.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_P=${P/_beta/b}
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/pylint-dev/pylint/
+"
+SRC_URI="
+ https://github.com/pylint-dev/pylint/archive/v${PV/_beta/b}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/pylint-dev/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-3.1[${PYTHON_USEDEP}]
+ >=dev-python/astroid-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+
+ # incompatible versions of numpy/scikit-learn?
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ 'tests/test_functional.py::test_functional[shadowed_import]'
+ )
+ local EPYTEST_IGNORE=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+ )
+
+ rm -rf pylint || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p timeout
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}