summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-22 16:09:16 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-22 16:24:55 +0100
commit3cd9b6b063057fd978cffa8408a6e2e0d9271bd3 (patch)
treeb9416ec3da644d19fe56e2a12d647e88de02d479 /dev-python/pylint
parentdev-embedded/xa: add 2.4.0 (diff)
downloadgentoo-3cd9b6b063057fd978cffa8408a6e2e0d9271bd3.tar.gz
gentoo-3cd9b6b063057fd978cffa8408a6e2e0d9271bd3.tar.bz2
gentoo-3cd9b6b063057fd978cffa8408a6e2e0d9271bd3.zip
dev-python/pylint: enable pypy3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/pylint-3.0.2.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/pylint/pylint-3.0.2.ebuild b/dev-python/pylint/pylint-3.0.2.ebuild
index 9f66ca157073..45c911979549 100644
--- a/dev-python/pylint/pylint-3.0.2.ebuild
+++ b/dev-python/pylint/pylint-3.0.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -44,7 +44,9 @@ RDEPEND="
"
BDEPEND="
test? (
- >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ ' 'python*' )
dev-python/pytest-timeout[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]
)
@@ -66,6 +68,15 @@ python_test() {
tests/benchmark/test_baseline_benchmarks.py
)
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ # Requires GitPython
+ EPYTEST_IGNORE+=(
+ tests/profile/test_profile_against_externals.py
+ tests/testutils/_primer/test_package_to_lint.py
+ tests/testutils/_primer/test_primer.py
+ )
+ fi
+
rm -rf pylint || die
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1