summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-14 07:08:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-14 07:33:49 +0200
commit1ee50f04cb4176dd637d37ed654fe242a4b5fb01 (patch)
tree6d8f3299c884f90a3aa805af411675e5978abb3c /dev-python/pymdown-extensions
parentdev-python/starlette: Bump to 0.30.0 (diff)
downloadgentoo-1ee50f04cb4176dd637d37ed654fe242a4b5fb01.tar.gz
gentoo-1ee50f04cb4176dd637d37ed654fe242a4b5fb01.tar.bz2
gentoo-1ee50f04cb4176dd637d37ed654fe242a4b5fb01.zip
dev-python/pymdown-extensions: Remove broken USE=doc
The doc logic is broken and does not check for Python matches properly. The use case doesn't seem to be supported by docs.eclass, and the hack just doesn't work anymore. Closes: https://bugs.gentoo.org/910278 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pymdown-extensions')
-rw-r--r--dev-python/pymdown-extensions/pymdown-extensions-10.0.1.ebuild25
1 files changed, 1 insertions, 24 deletions
diff --git a/dev-python/pymdown-extensions/pymdown-extensions-10.0.1.ebuild b/dev-python/pymdown-extensions/pymdown-extensions-10.0.1.ebuild
index c4ce98746073..6f87825fe59e 100644
--- a/dev-python/pymdown-extensions/pymdown-extensions-10.0.1.ebuild
+++ b/dev-python/pymdown-extensions/pymdown-extensions-10.0.1.ebuild
@@ -6,17 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( python3_{10..12} )
-DOCS_BUILDER="mkdocs"
-DOCS_DEPEND="
- dev-python/mkdocs-git-revision-date-localized-plugin
- dev-python/mkdocs-minify-plugin
- dev-python/mkdocs-material
- dev-python/pymdown-lexers
- dev-python/pyspelling
-"
-DOCS_INITIALIZE_GIT=1
-
-inherit distutils-r1 docs
+inherit distutils-r1
DESCRIPTION="Extensions for Python Markdown"
HOMEPAGE="
@@ -44,16 +34,3 @@ BDEPEND="
"
distutils_enable_tests pytest
-
-python_compile_all() {
- default
- # We need to do this manually instead of relying on docs_compile
- # https://bytemeta.vip/repo/facelessuser/pymdown-extensions/issues/1446
- # https://bugs.gentoo.org/859637
- if use doc; then
- python -m mkdocs build || die "Failed to make docs"
- # Colliding files found by ecompress:
- rm site/sitemap.xml.gz || die
- HTML_DOCS=( "site/." )
- fi
-}