summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 18:52:21 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 19:02:40 +0100
commit9a1ec2c87ed53bfdf39ae24d15382ea4e7d965a0 (patch)
tree1bbccbac137741a673c605f3c10326fdfe315d22 /dev-python/pympler/pympler-0.5.ebuild
parentdev-python/pympler: Stabilize 0.6 ALLARCHES (diff)
downloadgentoo-9a1ec2c87ed53bfdf39ae24d15382ea4e7d965a0.tar.gz
gentoo-9a1ec2c87ed53bfdf39ae24d15382ea4e7d965a0.tar.bz2
gentoo-9a1ec2c87ed53bfdf39ae24d15382ea4e7d965a0.zip
dev-python/pympler: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pympler/pympler-0.5.ebuild')
-rw-r--r--dev-python/pympler/pympler-0.5.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pympler/pympler-0.5.ebuild b/dev-python/pympler/pympler-0.5.ebuild
deleted file mode 100644
index 1026066d1f6e..000000000000
--- a/dev-python/pympler/pympler-0.5.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="Pympler"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Memory profiling for Python applications"
-HOMEPAGE="https://pypi.org/project/Pympler/ https://github.com/pympler/pympler"
-SRC_URI="https://github.com/pympler/pympler/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# The PyPi tarball is missing the documentation
-#SRC_URI="mirror://pypi/P/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/bottle[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND} )"
-
-python_compile_all() {
- if use doc; then
- python_setup
- sphinx-build -b html doc/{source,html} || die
- fi
-}
-
-python_test() {
- esetup.py try
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- distutils-r1_python_install_all
-}