summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-08 09:15:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-08 09:25:22 +0100
commitf3d39215a379e4843fa54037298d1ed131ab5619 (patch)
tree68598f3a2c0c38cbd69ef81129a22a2281abe2d5 /dev-python/pyparsing
parentdev-python/iso8601: Bump to 1.0.0 (diff)
downloadgentoo-f3d39215a379e4843fa54037298d1ed131ab5619.tar.gz
gentoo-f3d39215a379e4843fa54037298d1ed131ab5619.tar.bz2
gentoo-f3d39215a379e4843fa54037298d1ed131ab5619.zip
dev-python/pyparsing: Bump to 3.0.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest1
-rw-r--r--dev-python/pyparsing/pyparsing-3.0.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
index 5c9e40950db5..cfe378d950f2 100644
--- a/dev-python/pyparsing/Manifest
+++ b/dev-python/pyparsing/Manifest
@@ -3,3 +3,4 @@ DIST pyparsing_3.0.0.tar.gz 935578 BLAKE2B 2932fb8da83f4f7b0ba98057002c870ab54f5
DIST pyparsing_3.0.1.tar.gz 936219 BLAKE2B cc7dc4670f37a09e98c8bda785bac4121150f1a48438cc42c6fbf0546531e7fc674f2bfe1c85aba66ac1075b9c086d9ee30672a3eebc60efec21fd51772f577f SHA512 70f2f957c713a88979ae95de8834a79c777196a2a6d47a25bf930cdefdc3120919147a33119ada0d33c53bb215fcddfa969b0d1630d2979c9e685d85e5c57414
DIST pyparsing_3.0.3.tar.gz 938435 BLAKE2B 5237244693759ffc19637b4d8ee52f98b7160160c1f422a1720b9a8848025f37cb8b314aae505acb7696cc1546c495d049a6a93b3824d784b89aee3565001a4a SHA512 19735a3125620716a0a843156e6e9285c7811aa4db876fdc9fed7413dff77c0670fea5a0a16bc074704c6fec45f0129d1a3680b2123abf3c414fa75d73e03d36
DIST pyparsing_3.0.4.tar.gz 939837 BLAKE2B 27130518d1f3a4e497ecd4fa1fc624516bcb62488baf881ae3c8888bca48c957a4c6f0bf8d29aeeca8b1aa907c04ca41f3a61e876b78f1ea50684e24b12a2422 SHA512 01acf9b7663feae57e82ac3139c35687ea2754874425acfcf29b82595977660dab86ec35665e96400eb92acfbb51fb2326e010b960be7570de7575296078bd31
+DIST pyparsing_3.0.5.tar.gz 940615 BLAKE2B 7ca78eb4ddd769a49f9538757fc3aae1a1fa11ed1a8fd4483ac80bf50b483e0a8ca5ee13739fbb8c40a6009e3dd48aabab6fbb29fdd01f6f82c11b22348408e1 SHA512 b3efebc911f3c3850ebbb573299a843aab1ca2fb612e41d93947f59ebba9a716ca099b5ec2f9ad8091cb82f6018910205d8409c403f26fb64e72cbb474d05223
diff --git a/dev-python/pyparsing/pyparsing-3.0.5.ebuild b/dev-python/pyparsing/pyparsing-3.0.5.ebuild
new file mode 100644
index 000000000000..5e4cb765d6ac
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-3.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2004-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=${P/-/_}
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="https://github.com/pyparsing/pyparsing https://pypi.org/project/pyparsing/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz"
+S=${WORKDIR}/${PN}-${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # railroad-diagrams not packaged (and not suitable for packaging yet)
+ tests/test_diagram.py
+)
+
+EPYTEST_DESELECT=(
+ # also railroad-diagrams
+ tests/test_unit.py::Test02_WithoutPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test04_WithPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test06_WithBoundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test08_WithUnboundedPackrat::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test09_WithLeftRecursionParsing::testEmptyExpressionsAreHandledProperly
+ tests/test_unit.py::Test10_WithLeftRecursionParsingBoundedMemo::testEmptyExpressionsAreHandledProperly
+)
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}