summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-24 07:22:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-24 08:10:51 +0200
commit79a2060f9da481256d13511f691f3010aa7e072f (patch)
tree9985d759aee961cf1af50b28fb70ca0737918c16 /dev-python/pypdf/pypdf-3.11.0.ebuild
parentdev-python/zope-event: Bump to 5.0 (diff)
downloadgentoo-79a2060f9da481256d13511f691f3010aa7e072f.tar.gz
gentoo-79a2060f9da481256d13511f691f3010aa7e072f.tar.bz2
gentoo-79a2060f9da481256d13511f691f3010aa7e072f.zip
dev-python/pypdf: Bump to 3.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypdf/pypdf-3.11.0.ebuild')
-rw-r--r--dev-python/pypdf/pypdf-3.11.0.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pypdf/pypdf-3.11.0.ebuild b/dev-python/pypdf/pypdf-3.11.0.ebuild
new file mode 100644
index 000000000000..100ff908c051
--- /dev/null
+++ b/dev-python/pypdf/pypdf-3.11.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=69b31cff6b183a42f9081709ef9bee4047976f56
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ # TODO: requires fpdf
+ tests/test_page.py::test_compression
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ epytest -o addopts= -m "not enable_socket"
+}