summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-02 20:50:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-02 20:52:19 +0200
commitd42eaf8ed1634b74d835e7409ba6cf0de1796fca (patch)
tree70d3f52781f8ef78b10cfcb6db07b158e19f792b /dev-python/pyproject-fmt
parentdev-python/sqlalchemy: Remove old (diff)
downloadgentoo-d42eaf8ed1634b74d835e7409ba6cf0de1796fca.tar.gz
gentoo-d42eaf8ed1634b74d835e7409ba6cf0de1796fca.tar.bz2
gentoo-d42eaf8ed1634b74d835e7409ba6cf0de1796fca.zip
dev-python/pyproject-fmt: Add missing test dep on dev-python/tox
Closes: https://bugs.gentoo.org/905270 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-fmt')
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-0.13.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-0.13.0-r1.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..f5be7a8828e6
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-0.13.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/natsort-8.3.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.8[${PYTHON_USEDEP}]
+"
+# tox is called as a subprocess, to get targets from tox.ini
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
+ )
+"
+
+distutils_enable_tests pytest