summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-24 07:41:24 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-24 08:01:48 +0100
commitfcc306b0f96991d1e743099629ebd9f7388a1209 (patch)
treecf7a80b7eabd3c3c8446f1a270e1911b92817282 /dev-python/pytest-salt-factories
parentdev-python/scikit-build-core: Bump to 0.8.0 (diff)
downloadgentoo-fcc306b0f96991d1e743099629ebd9f7388a1209.tar.gz
gentoo-fcc306b0f96991d1e743099629ebd9f7388a1209.tar.bz2
gentoo-fcc306b0f96991d1e743099629ebd9f7388a1209.zip
dev-python/pytest-salt-factories: Bump to 1.0.0_rc29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-salt-factories')
-rw-r--r--dev-python/pytest-salt-factories/Manifest1
-rw-r--r--dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc29.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/pytest-salt-factories/Manifest b/dev-python/pytest-salt-factories/Manifest
index 556d3f94fcc7..c89c1aa324dc 100644
--- a/dev-python/pytest-salt-factories/Manifest
+++ b/dev-python/pytest-salt-factories/Manifest
@@ -2,3 +2,4 @@ DIST pytest-salt-factories-1.0.0_rc20.gh.tar.gz 160140 BLAKE2B 7ecd9af695626c465
DIST pytest-salt-factories-1.0.0_rc23.gh.tar.gz 162711 BLAKE2B 28610679d7717d7a6f97a2f14a1ac838aec5101171ae65f2328d9b902d04b272c5e37f08d8ff3414af52ff7af954da24c083dfdc4afd1a9342b09cce0bf5aec3 SHA512 22d8f4a1c48a144437b9ff7d064760b59bb2a1003838e07f446a6150a77c162bffa7f21c570f796d8214d870d5b029e92abf7b0410ce19726085b607628364f0
DIST pytest-salt-factories-1.0.0_rc25.gh.tar.gz 166148 BLAKE2B 11935c0164727968b9f2bd6f77498ea9ed4dbafd48bd6bb2730716fbcb1bb69b1ab09ef9ea2e2519368f4b6408bbb03f41fb0e52fc3cf75695f2b9c2b8d37294 SHA512 dd18688731b6bd2384abff9d739154b1ca7786bc3843d9fa8c293d1950925fff6c5820680a8095d4d5f3b75bcaeb07d8b3c7703ecab64a5f3a28bad11da18397
DIST pytest-salt-factories-1.0.0_rc28.gh.tar.gz 168150 BLAKE2B c286c2a3933f8a987f1073ba97097cec29bf494cac9c4ba21ec4c261e22570ac3445900cacf629cce6253fb1a5fb95eb3d637b4d26e8835648dd11c569a7255e SHA512 ea362daa83007d9054b023ca9c11864ba304d802fa359c8cb883aa929f339c5347d50560a2d4a9cbc151a7b05bc46d1dc2f7693dd32d26383766cb5f249f3484
+DIST pytest-salt-factories-1.0.0_rc29.gh.tar.gz 168690 BLAKE2B d365cdef727e6ed0c0d2d06ce3c8731ddf67181d4d8386d106b7569c709fc5336529c72e907d44496463b47b18659376a64c79b08d45aaa5aa7d8d927a646db3 SHA512 7dd0e9d5bb6e4b292ef145f6fec770435f1cd23a07be67c98e155b1aa3a34bec1c542d97a6cae0302ad46e5c2f4e35eadb45bd7ea8979c05c6ddf1aacde9f755
diff --git a/dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc29.ebuild b/dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc29.ebuild
new file mode 100644
index 000000000000..2f686d16d9bf
--- /dev/null
+++ b/dev-python/pytest-salt-factories/pytest-salt-factories-1.0.0_rc29.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="The new generation of the pytest-salt Plugin"
+HOMEPAGE="
+ https://github.com/saltstack/pytest-salt-factories/
+ https://pypi.org/project/pytest-salt-factories/
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-salt-factories/archive/${PV//_/}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P//_/}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/docker[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ dev-python/pytest-skip-markers[${PYTHON_USEDEP}]
+ dev-python/pytest-system-statistics[${PYTHON_USEDEP}]
+ >=dev-python/pytest-shell-utilities-1.4.0[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ >=app-admin/salt-3005.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ sed -i -e 's:helpers_namespace:pytest_&.plugin:' tests/conftest.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/integration/factories/daemons/ssh/test_salt_ssh.py::test_salt_ssh
+ tests/integration/factories/daemons/sshd/test_sshd.py::test_connect
+ tests/scenarios/examples/test_echoext.py::test_echoext
+ )
+
+ local ret tempdir x
+ # ${T} is too long a path for the tests to work
+ tempdir="$(mktemp -du --tmpdir=/tmp salt-XXX)" || die
+ addwrite "${tempdir}"
+
+ local -x SHELL="/bin/bash" TMPDIR="${tempdir}"
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=saltfactories.plugins
+ PYTEST_PLUGINS+=,pytest_helpers_namespace.plugin
+ PYTEST_PLUGINS+=,pytestsysstats.plugin
+ PYTEST_PLUGINS+=,pytest_subtests
+ for x in factories markers sysinfo event_listener log_server loader
+ do
+ PYTEST_PLUGINS+=,saltfactories.plugins.${x}
+ done
+
+ nonfatal epytest --no-sys-stats
+ ret=${?}
+
+ rm -rf "${tempdir}" || die
+ [[ ${ret} -ne 0 ]] && die "Tests failed with ${EPYTHON}"
+}