summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-21 08:40:40 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-21 08:51:11 +0100
commit06f2e649cb24df4be381416850e1d969f740f4ce (patch)
treeed637739e241d99cf9ee98a7b0891e1846849896 /dev-python/pytest-skip-markers
parentdev-python/httpcore: Bump to 0.16.3 (diff)
downloadgentoo-06f2e649cb24df4be381416850e1d969f740f4ce.tar.gz
gentoo-06f2e649cb24df4be381416850e1d969f740f4ce.tar.bz2
gentoo-06f2e649cb24df4be381416850e1d969f740f4ce.zip
dev-python/pytest-skip-markers: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-skip-markers')
-rw-r--r--dev-python/pytest-skip-markers/Manifest1
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.4.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pytest-skip-markers/Manifest b/dev-python/pytest-skip-markers/Manifest
index e7796822f22a..263def642957 100644
--- a/dev-python/pytest-skip-markers/Manifest
+++ b/dev-python/pytest-skip-markers/Manifest
@@ -1 +1,2 @@
DIST pytest-skip-markers-1.3.0.tar.gz 79882 BLAKE2B 2c44711e6194aebf0a0299f8a50e6162a088023c2fff6bdb7c142060695a6977b1d4a5cc574199d8f11a5a94e413d7444f81d9e954327e8317ed1bcf3725a60f SHA512 bea602032a7796be7c2dad62ba750e987b77f04349c96f6f8e1f15f5d2b58c3ba1e549a775ce7e541f6041091a578def59900a726872c8aa8b31c585e3f0c3e0
+DIST pytest-skip-markers-1.4.0.gh.tar.gz 70932 BLAKE2B d1bd597de0004ca37d8582896166be8f70833b386adbb53e5f812b28ac15bca613fea5e85b21bfb3549892f45ea8bbff13e66bafb97fc5db93e2fc6226a73c85 SHA512 6cb88833fd328f8e7cc6a2d0c8a0c9106b07186b8a20164c8272d685e93c21b111d4e7885ac1739ce777a9279a59705229ea41c3c31c71ac71d1bc26c13318f2
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.4.0.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.4.0.ebuild
new file mode 100644
index 000000000000..7e0bc9688443
--- /dev/null
+++ b/dev-python/pytest-skip-markers/pytest-skip-markers-1.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Pytest plugin which implements a few useful skip markers"
+HOMEPAGE="
+ https://pytest-skip-markers.readthedocs.io/en/latest/
+ https://github.com/saltstack/pytest-skip-markers
+"
+SRC_URI="
+ https://github.com/saltstack/pytest-skip-markers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.1.0[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytestskipmarkers.plugin,pyfakefs.pytest_plugin
+ epytest
+}