summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-03-26 21:52:32 +0000
committerMarek Szuba <marecki@gentoo.org>2022-03-26 22:31:17 +0000
commit90ee6d436ea866ae4abb39fc28d5357c3d920d73 (patch)
tree422fb76dba8077535fb4e1f212041f5757b8da9a /dev-python/pytest-testinfra
parentdev-python/meshio: drop 5.3.2 (diff)
downloadgentoo-90ee6d436ea866ae4abb39fc28d5357c3d920d73.tar.gz
gentoo-90ee6d436ea866ae4abb39fc28d5357c3d920d73.tar.bz2
gentoo-90ee6d436ea866ae4abb39fc28d5357c3d920d73.zip
dev-python/pytest-testinfra: drop 6.4.0, 6.5.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest2
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild33
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild45
3 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index 05fc02866acf..a4654b7565e3 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1,3 +1 @@
-DIST pytest-testinfra-6.4.0.tar.gz 77516 BLAKE2B 2baf5940e8736cbe78d8017a82b3a8fdb6df95b89acccd49ecd354447b7ea88079f48211e0acea46a0d8702b67609fe6f85f730c66e781a99d8a92b52b3c99b9 SHA512 acd2c7f9daeb391815a32c972a3542c0d643a716f3cffcb66f4203435ebac789333edb91c83d2778ae8da93b676b245fd47821bca9218faa3e7b50e6764087f4
-DIST pytest-testinfra-6.5.0.tar.gz 77177 BLAKE2B 98a8f10f7cf62f204c117d295496a7dfa4de476f5cde457af6f5bc71b22e12e9f02b4893adc6b0d1be11915ed652f628c2574fd44750c82c690e3d8326e29c4c SHA512 f7fcf8facafc0d99b06f55f4241c39b610ff7648b0049c584a75b46944b522b957c98c353f147d74bc8a72f677a179380c456b0868f9dae9af514a9c95d55b13
DIST pytest-testinfra-6.6.0.tar.gz 78285 BLAKE2B c7583685aeb770f76e4679730599909b8fff53d1909664f55e2d35f7f5a6a96741e3aa56b81da464c2d474d1d5f646892e36a4f9b6938327cb526476536b0b6c SHA512 f78f1cd5240e157d4e2949178f29900a7b85a6065b4113b18273af3f1fef6b19c859192f59426b93eba48418bb89d163ad1d951e97d4fdfcea4394635a05140a
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild
deleted file mode 100644
index c336646d0373..000000000000
--- a/dev-python/pytest-testinfra/pytest-testinfra-6.4.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Write unit tests in Python to test actual state of your servers"
-HOMEPAGE="https://github.com/pytest-dev/pytest-testinfra"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-# Ansible is called via its CLI
-BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- app-admin/ansible
- app-admin/salt[${PYTHON_USEDEP}]
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/pywinrm[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-pkg_postinst() {
- elog "For the list of available connection back-ends and their dependencies,"
- elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
-}
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild
deleted file mode 100644
index a10a5d492b91..000000000000
--- a/dev-python/pytest-testinfra/pytest-testinfra-6.5.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Write unit tests in Python to test actual state of your servers"
-HOMEPAGE="https://github.com/pytest-dev/pytest-testinfra"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
-# Ansible is called via its CLI
-BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- app-admin/ansible
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/pywinrm[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- app-admin/salt[${PYTHON_USEDEP}]
- ' python3_{8..9} )
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- if [[ ${EPYTHON} == "python3.10" ]]; then
- ewarn "Some of the tests are skipped on ${EPYTHON} because it still isn't supported by app-admin/salt"
- local EPYTEST_DESELECT=(
- test/test_backends.py::test_backend_importables
- )
- fi
- epytest
-}
-
-pkg_postinst() {
- elog "For the list of available connection back-ends and their dependencies,"
- elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
-}