summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-20 07:30:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-20 07:34:53 +0200
commitcf665ab8b9db969d8f8df97a29d4fa75b7fe5bb7 (patch)
tree052a1d486db27b5d8d17242c4d0f82012ca1228a /dev-python/pytest-testinfra
parentdev-python/sybil: Bump to 5.0.2 (diff)
downloadgentoo-cf665ab8b9db969d8f8df97a29d4fa75b7fe5bb7.tar.gz
gentoo-cf665ab8b9db969d8f8df97a29d4fa75b7fe5bb7.tar.bz2
gentoo-cf665ab8b9db969d8f8df97a29d4fa75b7fe5bb7.zip
dev-python/pytest-testinfra: Bump to 8.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-testinfra')
-rw-r--r--dev-python/pytest-testinfra/Manifest1
-rw-r--r--dev-python/pytest-testinfra/pytest-testinfra-8.0.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pytest-testinfra/Manifest b/dev-python/pytest-testinfra/Manifest
index 8624198679b5..2821fbb33404 100644
--- a/dev-python/pytest-testinfra/Manifest
+++ b/dev-python/pytest-testinfra/Manifest
@@ -1 +1,2 @@
DIST pytest-testinfra-7.0.0.tar.gz 79296 BLAKE2B b0870cbf466627daff0ed6a3063c15c9b725fab4009fc24c3779b56765901e6b8d3a42fce429f1e42151b78d61f52c38955772e562c74d78c717a61a5fe74f04 SHA512 507d7a434c2eb159e2c36b1be3d447e386d3a4e614f2717ed8add456358f644c18f801db6774a4854e4ec7936643febd332aa4096ab26ae0080aceeff420c78e
+DIST pytest-testinfra-8.0.0.tar.gz 83448 BLAKE2B e1dcd7f685183ad0d1c79f3fe7542797f2c91839faf79e2b368c0e330aec22a420621859d419f7816b72df4aad9ac9d5ecc99d257804311d6b8b77c20b5b833b SHA512 ee8e8df7ba0422ea60d55149495a682b88a62646b6b601dd95a135a5d3a131d5cc57cb0f0cc0ff7166d004758619283480e52b8507cc2eedbc25c46a16da60b5
diff --git a/dev-python/pytest-testinfra/pytest-testinfra-8.0.0.ebuild b/dev-python/pytest-testinfra/pytest-testinfra-8.0.0.ebuild
new file mode 100644
index 000000000000..ac3689c80baf
--- /dev/null
+++ b/dev-python/pytest-testinfra/pytest-testinfra-8.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Write unit tests in Python to test actual state of your servers"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-testinfra/
+ https://pypi.org/project/pytest-testinfra/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# Ansible is called via its CLI
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ app-admin/ansible
+ $(python_gen_cond_dep '
+ app-admin/salt[${PYTHON_USEDEP}]
+ ' python3_10)
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pywinrm[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x EPYTEST_DESELECT=()
+
+ # This is the only test which actually fails if salt cannot be imported
+ if [[ ${EPYTHON} == python3.11 ]]; then
+ EPYTEST_DESELECT+=(
+ test/test_backends.py::test_backend_importables
+ )
+ fi
+
+ epytest
+}
+
+pkg_postinst() {
+ elog "For the list of available connection back-ends and their dependencies,"
+ elog "please consult https://testinfra.readthedocs.io/en/latest/backends.html"
+}