summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:43:25 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:56:01 +0100
commitbee03e2db6de9318ed9b8f9b9634cb12e3738006 (patch)
tree63d4c4bb1424ec8df3db97fd8bfcb3f1969ff07c /dev-python/python-axolotl-curve25519
parentdev-python/python-axolotl: drop 0.2.3-r1 (diff)
downloadgentoo-bee03e2db6de9318ed9b8f9b9634cb12e3738006.tar.gz
gentoo-bee03e2db6de9318ed9b8f9b9634cb12e3738006.tar.bz2
gentoo-bee03e2db6de9318ed9b8f9b9634cb12e3738006.zip
dev-python/python-axolotl-curve25519: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/python-axolotl-curve25519')
-rw-r--r--dev-python/python-axolotl-curve25519/python-axolotl-curve25519-0.4.1_p2-r2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/python-axolotl-curve25519/python-axolotl-curve25519-0.4.1_p2-r2.ebuild b/dev-python/python-axolotl-curve25519/python-axolotl-curve25519-0.4.1_p2-r2.ebuild
new file mode 100644
index 000000000000..c46ea49e41ef
--- /dev/null
+++ b/dev-python/python-axolotl-curve25519/python-axolotl-curve25519-0.4.1_p2-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PV="${PV/_p/-}"
+
+DESCRIPTION="A python wrapper for the curve25519 library with ed25519 signatures"
+HOMEPAGE="https://github.com/tgalal/python-axolotl-curve25519"
+SRC_URI="https://github.com/tgalal/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~riscv x86"