summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-11 13:56:59 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-16 20:20:45 +0200
commit8ee495cc1cd0e9dfc548e4ebc7fffa21f063a4ba (patch)
tree3295cb86d6fcd1f3707e34a9f6440dc88035de3a /dev-python/python-blazarclient
parentdev-python/snappy: correct DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-8ee495cc1cd0e9dfc548e4ebc7fffa21f063a4ba.tar.gz
gentoo-8ee495cc1cd0e9dfc548e4ebc7fffa21f063a4ba.tar.bz2
gentoo-8ee495cc1cd0e9dfc548e4ebc7fffa21f063a4ba.zip
dev-python/python-blazarclient: correct DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/747256 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-blazarclient')
-rw-r--r--dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild b/dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild
index a9a887a6d89d..533f29618d77 100644
--- a/dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild
+++ b/dev-python/python-blazarclient/python-blazarclient-2.1.0.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_6 python3_7 )
inherit distutils-r1
@@ -17,8 +19,7 @@ IUSE=""
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
!~dev-python/pbr-2.1.0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
+DEPEND="${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]