summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-03-27 14:43:44 +0100
committerSebastian Pipping <sping@gentoo.org>2021-03-27 14:43:44 +0100
commit64fb1a0428d43799f458bc342ea1d771a9b29e44 (patch)
tree87fadc82ac546324df9e3964c59f85c9f1345068 /dev-python/python-dotenv
parentsys-kernel/genkernel: bump to v4.2.1 (diff)
downloadgentoo-64fb1a0428d43799f458bc342ea1d771a9b29e44.tar.gz
gentoo-64fb1a0428d43799f458bc342ea1d771a9b29e44.tar.bz2
gentoo-64fb1a0428d43799f458bc342ea1d771a9b29e44.zip
dev-python/python-dotenv: 0.16.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.17, Repoman-3.0.2
Diffstat (limited to 'dev-python/python-dotenv')
-rw-r--r--dev-python/python-dotenv/Manifest1
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.16.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/Manifest b/dev-python/python-dotenv/Manifest
index 75e8eca5d6ea..d6deed653817 100644
--- a/dev-python/python-dotenv/Manifest
+++ b/dev-python/python-dotenv/Manifest
@@ -1 +1,2 @@
DIST python-dotenv-0.15.0.tar.gz 30008 BLAKE2B 1a406145f0d0497aa037dc95b80fb04854b2889ba4014e4689a24b142d5d71c49d24ac60406f8b2dc873e661c19e36604ef58eb03c7bc9f890f6d4561be199a6 SHA512 f1f16d2688041259027b12920ac5f47c2d1d96cfc3ec8a362a05ddfb13fee2cf4926c20ad38eda521fcafb6eef8d7895d86dedadef1b1ea2ecd7e33734b07cbe
+DIST python-dotenv-0.16.0.tar.gz 30903 BLAKE2B 10a737d819bbede558ef87e79b64c4347d05e3dc2bcf76877daf2f3a7afe80230dc95bd2667a7ab6adaad3507d3e55d061b1b43f09f1710778683e79c5aef928 SHA512 8025e3c1e3c2eb5276b13716f3f2f002151c699fa9837d61762fb8bc8b5fe9b58498905ff1689bc62c49612b8d81066e80e0a289164451f5b757bdc6bc0c46eb
diff --git a/dev-python/python-dotenv/python-dotenv-0.16.0.ebuild b/dev-python/python-dotenv/python-dotenv-0.16.0.ebuild
new file mode 100644
index 000000000000..327601a0effa
--- /dev/null
+++ b/dev-python/python-dotenv/python-dotenv-0.16.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Manage .env files"
+HOMEPAGE="https://github.com/theskumar/python-dotenv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sh-1.09[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Tests call the "dotenv" command which needs to be in PATH
+ # https://bugs.gentoo.org/743784
+ distutils_install_for_testing
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}