summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-17 05:54:02 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-17 06:24:08 +0100
commit2fa2915b6c151d4e4c0e9b849d197ab912a7fc2a (patch)
tree9431c848c1ef344c15eb539d6c995d04d5d94edb /dev-python/python-engineio
parentdev-python/pybind11: Bump to 2.10.4 (diff)
downloadgentoo-2fa2915b6c151d4e4c0e9b849d197ab912a7fc2a.tar.gz
gentoo-2fa2915b6c151d4e4c0e9b849d197ab912a7fc2a.tar.bz2
gentoo-2fa2915b6c151d4e4c0e9b849d197ab912a7fc2a.zip
dev-python/python-engineio: Bump to 4.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-4.4.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index 1dedeaffeac0..2e769948f6fb 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1 +1,2 @@
DIST python-engineio-4.3.4.gh.tar.gz 300665 BLAKE2B 78488fb7deb54136a255b1027e52e1869e7d09b38769d3dd144b26146ac8db58091238c3f1cfa81d4c29af4d1bd8bb998559756053e53f6c7876c2866da31575 SHA512 427f224ae24d939d55316931cd087676741195d578415224de291f9871b535fdd02b835ac32a65d73be0428c8c4be0414faefca06a4964b1fe34e2ac91b02694
+DIST python-engineio-4.4.0.gh.tar.gz 309353 BLAKE2B 4cf40802fddcce2e53e205bdbe73bdf0ec822e15581fe4a9939b8d05c3eb6ba82a99d089d4708169b197aa79e5b5f14001ff86f72025fc6d96c99ed6d73fe620 SHA512 b7995aaf2583ec58ac87f048608653ade3846dd103616ee90b3dc12cc7e27c7d37959cd3e1ebf6e138395ff6fad8cd011407b6660258715e513bf72c8a3e1f6f
diff --git a/dev-python/python-engineio/python-engineio-4.4.0.ebuild b/dev-python/python-engineio/python-engineio-4.4.0.ebuild
new file mode 100644
index 000000000000..75393f34860c
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-4.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Engine.IO realtime server"
+HOMEPAGE="
+ https://python-engineio.readthedocs.io/
+ https://github.com/miguelgrinberg/python-engineio/
+ https://pypi.org/project/python-engineio/"
+SRC_URI="
+ https://github.com/miguelgrinberg/python-engineio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+"
+# Can use eventlet, werkzeug, or gevent, but no tests for werkzeug
+BDEPEND="
+ test? (
+ dev-python/tornado[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+EPYTEST_IGNORE=(
+ # eventlet is masked for removal
+ tests/common/test_async_eventlet.py
+)
+
+EPYTEST_DESELECT=(
+ # also eventlet
+ tests/common/test_server.py::TestServer::test_async_mode_eventlet
+ tests/common/test_server.py::TestServer::test_connect
+ tests/common/test_server.py::TestServer::test_service_task_started
+ tests/common/test_server.py::TestServer::test_upgrades
+)