summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-19 06:53:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-19 07:10:56 +0100
commit55578031f745e42e0c58983e8c23b03c275c3065 (patch)
tree32c07bacc4df10053a42802a60b17ab5adf3696e /dev-python/python-lsp-black
parentdev-python/paramiko: add 3.4.0 (diff)
downloadgentoo-55578031f745e42e0c58983e8c23b03c275c3065.tar.gz
gentoo-55578031f745e42e0c58983e8c23b03c275c3065.tar.bz2
gentoo-55578031f745e42e0c58983e8c23b03c275c3065.zip
dev-python/python-lsp-black: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-lsp-black')
-rw-r--r--dev-python/python-lsp-black/Manifest1
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-2.0.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-lsp-black/Manifest b/dev-python/python-lsp-black/Manifest
index 3407923c9a61..cc7e22f85055 100644
--- a/dev-python/python-lsp-black/Manifest
+++ b/dev-python/python-lsp-black/Manifest
@@ -1 +1,2 @@
DIST python-lsp-black-1.3.0.gh.tar.gz 9781 BLAKE2B d079d7a95dff682b86df23825796d2fa6e89d1aa3e66da1452e576fd1e96a4c298da181f53840fe5fcdcbbc8a0ca55aa53cbc4885a0178b6402365ef41a239be SHA512 9e3d081ac022854626c120128949ab5e58c44f9e76ddd566e3b80a697fbc02a96f62994f43195b02f899e770768d55d223984267133eedd6f642b70560d46c09
+DIST python-lsp-black-2.0.0.gh.tar.gz 10399 BLAKE2B e38bf7ae736b3b71c1e17dd34b7e98b9bcbdbc7a12e2c1596ccdbe13b8fac8caef8a1f043aa50e1688b9159928885b8b116b709b4d2574b8ddf77172df756862 SHA512 e374ea34ac53e0d78ba198814210d9d7293e18b8fc7b22bb288621a994c8c9d492cc9c99c40cd1574b618add518671430e1e88f32e93e4c95507373932c08dc0
diff --git a/dev-python/python-lsp-black/python-lsp-black-2.0.0.ebuild b/dev-python/python-lsp-black/python-lsp-black-2.0.0.ebuild
new file mode 100644
index 000000000000..6092fe46fe78
--- /dev/null
+++ b/dev-python/python-lsp-black/python-lsp-black-2.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python LSP Server"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-black/
+ https://pypi.org/project/python-lsp-black/
+"
+SRC_URI="
+ https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-lsp-server-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/black-23.11.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ !!<dev-python/python-lsp-black-2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}