summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-08 23:24:15 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:04:45 -0500
commit9505c0e80ff1222316cce05d74a38d6debed7bab (patch)
treec507051c93646bc3bd0e68273a6485c3c9e65020 /dev-python/python-memcached
parentdev-python/pytz: 2018.9 bump (diff)
downloadgentoo-9505c0e80ff1222316cce05d74a38d6debed7bab.tar.gz
gentoo-9505c0e80ff1222316cce05d74a38d6debed7bab.tar.bz2
gentoo-9505c0e80ff1222316cce05d74a38d6debed7bab.zip
dev-python/python-memcached: 1.59 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-memcached')
-rw-r--r--dev-python/python-memcached/Manifest1
-rw-r--r--dev-python/python-memcached/python-memcached-1.59.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-memcached/Manifest b/dev-python/python-memcached/Manifest
index 5cf9fdc6e4a9..cd62e89c7c72 100644
--- a/dev-python/python-memcached/Manifest
+++ b/dev-python/python-memcached/Manifest
@@ -1,2 +1,3 @@
DIST python-memcached-1.53.tar.gz 35025 BLAKE2B 40d30ba35b8dc5d33c27a8a02d66ef7714c2851a3bb109b0cd4456f14408579e51baef8a6020ee75a21bfba468f6524c5163f4161676fc86788186832ff2ec4d SHA512 33ffd2778025a8e15beddf1660c4b5c9f1ba144adab5c36fd679e15508015c00e3e1185b5cc179cfcfc556b7c3ab44ed9914089e5ce9db66a04d0a658dd38bb3
DIST python-memcached-1.58.tar.gz 30562 BLAKE2B 928aeca2b0d6d99fb16ee8c8c970ccc41aabb4c6385d962cb4208878f4f0eb1b1114c103118fc4ce6020e01d2260b9ffa83e96b2aba719cad6820e39d9fcfe3c SHA512 48f933f095751b476c122473fa1d9767cfe5c6c339a9ba71825a50cec23cbfc7b6493716458bfb1f2451c634c517519152105a2000be66bd0d389f94ea312138
+DIST python-memcached-1.59.tar.gz 22210 BLAKE2B 50387821d50cf974ada738346e016eb736043078721bf905782f41df1f27574244d03b6b94ac9e5ccab7aeecfa8ca4c5a78cec2c41d15fda8756c7cb3bce9aa1 SHA512 a25cbb9efb3babe85e1523bdabfe4644b93b3a6a7268787a3928f724f833ce0eea7d2ef676d1b7f894cdfe293129975b35cb46ec553c92810dbc18013bfabece
diff --git a/dev-python/python-memcached/python-memcached-1.59.ebuild b/dev-python/python-memcached/python-memcached-1.59.ebuild
new file mode 100644
index 000000000000..bb6af4af9326
--- /dev/null
+++ b/dev-python/python-memcached/python-memcached-1.59.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python memcached client"
+HOMEPAGE="
+ https://www.tummy.com/Community/software/python-memcached/
+ https://pypi.org/project/python-memcached/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ net-misc/memcached
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+# Tests try to connect to memcached via TCP/IP. Please do not re-enable
+# until you get them all to pass properly while using the UNIX socket
+# only and not even trying to connect to memcached over TCP/IP.
+RESTRICT=test
+
+python_test() {
+ # Note: partial. Needs fixing. Stuff like that.
+
+ cd "${TMPDIR}" || die
+
+ local memcached_opts=( -d -P memcached.pid -s memcached.socket )
+ [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
+
+ memcached "${memached_opts[@]}" || die
+
+ "${PYTHON}" memcache.py --do-unix || die "Tests fail with ${EPYTHON}"
+
+ kill "$(<memcached.pid)" || die
+ rm memcached.pid || die
+}