summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-24 13:19:49 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-24 13:33:25 +0200
commit795643b6728a22901f7b6d42ec32bc11993f2764 (patch)
treec3c69a33e8e8cd84556d6ddf75bb50f9a4137381 /dev-python/python-rtmidi
parentdev-python/python-mpv: Remove old (diff)
downloadgentoo-795643b6728a22901f7b6d42ec32bc11993f2764.tar.gz
gentoo-795643b6728a22901f7b6d42ec32bc11993f2764.tar.bz2
gentoo-795643b6728a22901f7b6d42ec32bc11993f2764.zip
dev-python/python-rtmidi: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-rtmidi')
-rw-r--r--dev-python/python-rtmidi/Manifest1
-rw-r--r--dev-python/python-rtmidi/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch59
-rw-r--r--dev-python/python-rtmidi/python-rtmidi-1.4.9.ebuild52
3 files changed, 0 insertions, 112 deletions
diff --git a/dev-python/python-rtmidi/Manifest b/dev-python/python-rtmidi/Manifest
index 56940aca4fc3..1bc658cf76b4 100644
--- a/dev-python/python-rtmidi/Manifest
+++ b/dev-python/python-rtmidi/Manifest
@@ -1,2 +1 @@
-DIST python-rtmidi-1.4.9.tar.gz 251238 BLAKE2B dda4052e893839f88a6756306f8ff4e89ee66ad9716d374efbb7b92a8e9074e98c8d5df0cc82aa3c6e0c77a78fe9b997079623a5147c03eeea9128dfb7605215 SHA512 91c5a0f807549fbe9d87df6e40b8c3db0f9be753616ba51804900195d02120cd972e39c69dd99e60e4ea1b1d9831d0b956b64ce71b2fe03422efc57bccf5cb70
DIST python_rtmidi-1.5.4.tar.gz 327631 BLAKE2B c4bdbca7e011922eddb7995818cf471d0a3a5243c407b6ca82afad666af367beba4eec0a594ee26a2aca513b85f7964b81f9bd9d5ca095a03219382797402525 SHA512 2468ea12fcf6b741eefab7673a7d5d39322fccc853bd6e69ba77e90d6ee3e2681966d9886774386ddb395ee045fd266501c090707894bae5e47cf142c46fd0a4
diff --git a/dev-python/python-rtmidi/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch b/dev-python/python-rtmidi/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch
deleted file mode 100644
index 45cece4b2eb9..000000000000
--- a/dev-python/python-rtmidi/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch
+++ /dev/null
@@ -1,59 +0,0 @@
---- a/setup.py
-+++ b/setup.py
-@@ -102,7 +102,7 @@
-
- # Set up options for compiling the _rtmidi Extension
- if cythonize:
-- sources = [join(SRC_DIR, "_rtmidi.pyx"), join(SRC_DIR, "rtmidi", "RtMidi.cpp")]
-+ sources = [join(SRC_DIR, "_rtmidi.pyx")]
- elif exists(join(SRC_DIR, "_rtmidi.cpp")):
- cythonize = lambda x: x # noqa
- sources = [join(SRC_DIR, "_rtmidi.cpp"), join(SRC_DIR, "rtmidi", "RtMidi.cpp")]
-@@ -145,18 +145,13 @@
-
-
- if sys.platform.startswith('linux'):
-- if alsa and find_library('asound'):
-- define_macros.append(("__LINUX_ALSA__", None))
-- libraries.append('asound')
-+ if not find_library('rtmidi'):
-+ sys.exit("Failed to find librtmidi")
-
-- if jack:
-- check_for_jack(define_macros, libraries)
--
-- if not find_library('pthread'):
-- sys.exit("The 'pthread' library is required to build python-rtmidi on"
-- "Linux. Please install the libc6 development package.")
--
-- libraries.append("pthread")
-+ res = subprocess.check_output(['pkg-config', '--variable', 'includedir', 'rtmidi'])
-+ rtmidi_include_dir = res.decode().strip()
-+ include_dirs.append(rtmidi_include_dir)
-+ libraries.append('rtmidi')
- elif sys.platform.startswith('darwin'):
- if jack:
- check_for_jack(define_macros, libraries)
-@@ -197,7 +192,7 @@
- # Finally, set up our distribution
- setup(
- packages=['rtmidi'],
-- ext_modules=cythonize(extensions),
-+ ext_modules=cythonize(extensions, include_path=[ rtmidi_include_dir ]),
- tests_require=[], # Test dependencies are handled by tox
- # On systems without a RTC (e.g. Raspberry Pi), system time will be the
- # Unix epoch when booted without network connection, which makes zip fail,
---- a/tests/test_rtmidi.py
-+++ b/tests/test_rtmidi.py
-@@ -54,11 +54,6 @@
- else:
- self.assertEqual(res, rtmidi.API_UNSPECIFIED)
-
-- def test_get_rtmidi_version(self):
-- version = rtmidi.get_rtmidi_version()
-- self.assertTrue(isinstance(version, string_types))
-- self.assertEqual(version, '4.0.0')
--
-
- class BaseTests:
- NOTE_ON = [0x90, 48, 100]
diff --git a/dev-python/python-rtmidi/python-rtmidi-1.4.9.ebuild b/dev-python/python-rtmidi/python-rtmidi-1.4.9.ebuild
deleted file mode 100644
index 69f7947f93cd..000000000000
--- a/dev-python/python-rtmidi/python-rtmidi-1.4.9.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python bindings for media-libs/rtmidi implemented using Cython"
-HOMEPAGE="
- https://pypi.org/project/python-rtmidi/
- https://spotlightkid.github.io/python-rtmidi/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+alsa jack"
-
-# Most of these tests do not play nicely with the sandbox, some only
-# work with exactly the same version of rtmidi as the bundled one, and
-# several fail even with disabled sandbox unless there are actual MIDI
-# I/O devices present.
-RESTRICT="test"
-
-DEPEND="media-libs/rtmidi[alsa?,jack?]"
-RDEPEND="${DEPEND}"
-BDEPEND="<dev-python/cython-2.99[${PYTHON_USEDEP}]
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.4.9-unbundle_rtmidi.patch
-)
-
-distutils_enable_sphinx docs
-distutils_enable_tests unittest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # Just in case
- rm -r src/rtmidi || die
- rm src/_rtmidi.cpp || die
-}
-
-python_test() {
- cd "${T}" || die
- eunittest "${S}"/tests
-}