summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyzmq
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest3
-rw-r--r--dev-python/pyzmq/files/pyzmq-2.2.0.1-python3.patch34
-rw-r--r--dev-python/pyzmq/metadata.xml11
-rw-r--r--dev-python/pyzmq/pyzmq-14.4.1.ebuild60
-rw-r--r--dev-python/pyzmq/pyzmq-14.6.0.ebuild65
-rw-r--r--dev-python/pyzmq/pyzmq-14.7.0.ebuild65
6 files changed, 238 insertions, 0 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
new file mode 100644
index 000000000000..19f124f9e53d
--- /dev/null
+++ b/dev-python/pyzmq/Manifest
@@ -0,0 +1,3 @@
+DIST pyzmq-14.4.1.tar.gz 995366 SHA256 cb4a59875fdc26315045d800bac008b8e10a4cf2d72ac9af2fc45ef6ac8f330a SHA512 4b71677e4bfa771177a34dbff59cf6dfd54310a8996689a3d62902aaba35c7cf2ad6b7da806f9e189ad4b89fcefe9cbb3e192788eecd5d2c269e8a980b4d50fa WHIRLPOOL f6c093023b4494e1f9293a81ac86dcc55ff05f7ae10bb9677ff4fffd2e38fefe2462eb241c74b1ee283958a8546b128585c78c644dae544aa38f4b9c1f3e3ad8
+DIST pyzmq-14.6.0.tar.gz 1001020 SHA256 7746806ff94f1e8c1e843644c6bbd3b9aaeb1203c2eaf38879adc23dbd5c35bb SHA512 02e7feaca0ed73d48af2577fa9fc240e947bf9cea444b3819b8fd39fc2ca4b50c8f11ff27c8477386ef7bee1e8f5bbca50769403ab1393d43624065e647b6544 WHIRLPOOL e10c96a8852cd57dc7ec622405925c987a66cfecff125b6b664a8ab48078b6bea59749421122b7158ace0f366c6d61eb617e9b2f7e951000c9a61d86b87a2ff0
+DIST pyzmq-14.7.0.tar.gz 1048389 SHA256 77994f80360488e7153e64e5959dc5471531d1648e3a4bff14a714d074a38cc2 SHA512 22c30414c99bddb71f47b37f49f19b0cb1a535bdc6835fac13c78d030a59ed362124393acd41b7e04bb1f8ca231cabb49d010ac93142786ec35ee4a303f168ed WHIRLPOOL 82f1940133d23bc11acaaf66a92cebfdc76f844f990f90314198b3a65b2dd561e2ab7a5b532f76e6a9a6dd93520b7ae096331fb09eb302b898616e916d35e702
diff --git a/dev-python/pyzmq/files/pyzmq-2.2.0.1-python3.patch b/dev-python/pyzmq/files/pyzmq-2.2.0.1-python3.patch
new file mode 100644
index 000000000000..d6b1299add7a
--- /dev/null
+++ b/dev-python/pyzmq/files/pyzmq-2.2.0.1-python3.patch
@@ -0,0 +1,34 @@
+From 51f2470bce6c9e6067606aec2d9a018555582b30 Mon Sep 17 00:00:00 2001
+From: MinRK <benjaminrk@gmail.com>
+Date: Mon, 20 Aug 2012 22:44:27 -0700
+Subject: [PATCH] fix exception syntax in gevent.core
+
+---
+ zmq/green/core.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/zmq/green/core.py b/zmq/green/core.py
+index d4e5f73..9e5acdf 100644
+--- a/zmq/green/core.py
++++ b/zmq/green/core.py
+@@ -114,7 +114,7 @@ def _wait_write(self):
+ try:
+ timeout.start()
+ self.__writable.get(block=True)
+- except gevent.Timeout, t:
++ except gevent.Timeout as t:
+ if t is not timeout:
+ raise
+ toc = time.time()
+@@ -138,7 +138,7 @@ def _wait_read(self):
+ try:
+ timeout.start()
+ self.__readable.get(block=True)
+- except gevent.Timeout, t:
++ except gevent.Timeout as t:
+ if t is not timeout:
+ raise
+ toc = time.time()
+--
+1.7.10
+
diff --git a/dev-python/pyzmq/metadata.xml b/dev-python/pyzmq/metadata.xml
new file mode 100644
index 000000000000..4fecbd76e7e6
--- /dev/null
+++ b/dev-python/pyzmq/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <use>
+ <flag name="green">Enable gevent compatibility with zeromq</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">pyzmq</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyzmq/pyzmq-14.4.1.ebuild b/dev-python/pyzmq/pyzmq-14.4.1.ebuild
new file mode 100644
index 000000000000..3e47d450560f
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-14.4.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples green test"
+
+# Ensures installation of gevent for test phase
+REQUIRED_USE="test? ( green )"
+
+PY2_USEDEP=$(python_gen_usedep python2_7)
+RDEPEND=">=net-libs/zeromq-2.1.9:=
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ green? ( dev-python/gevent[${PY2_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )"
+
+python_configure_all() {
+ tc-export CC
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ if python_is_python3; then
+ einfo "Skipping python3 due to lack of support by gevent"
+ else
+ nosetests -svw "${BUILD_DIR}/lib/"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyzmq/pyzmq-14.6.0.ebuild b/dev-python/pyzmq/pyzmq-14.6.0.ebuild
new file mode 100644
index 000000000000..b7c52f8d3b40
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-14.6.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples green test"
+
+# Ensures installation of gevent for test phase
+REQUIRED_USE="test? ( green )"
+
+PY2_USEDEP=$(python_gen_usedep python2_7)
+RDEPEND="
+ >=net-libs/zeromq-4.1.2:=
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ green? ( dev-python/gevent[${PY2_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ tc-export CC
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ # suite reports error in absence of gevent under py3 but is designed to continue
+ # rather than exit making py3 apt for the test phase
+ nosetests -svw "${BUILD_DIR}/lib/"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyzmq/pyzmq-14.7.0.ebuild b/dev-python/pyzmq/pyzmq-14.7.0.ebuild
new file mode 100644
index 000000000000..f9824c33d9cc
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-14.7.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="http://www.zeromq.org/bindings:python http://pypi.python.org/pypi/pyzmq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples green test"
+
+# Ensures installation of gevent for test phase
+REQUIRED_USE="test? ( green )"
+
+PY2_USEDEP=$(python_gen_usedep python2_7)
+RDEPEND="
+ >=net-libs/zeromq-4.1.2:=
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ green? ( dev-python/gevent[${PY2_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? (
+ >=dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ tc-export CC
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ # suite reports error in absence of gevent under py3 but is designed to continue
+ # rather than exit making py3 apt for the test phase
+ nosetests -svw "${BUILD_DIR}/lib/"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}