summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-22 10:00:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-22 10:55:45 +0100
commit565028012e2de5f89adf918975a5d6a2b59b917b (patch)
treeb3a0435f6c8ea8461dec59717260b801e667044d /dev-python/qtconsole
parentdev-python/wcmatch: Bump to 8.0.1 (diff)
downloadgentoo-565028012e2de5f89adf918975a5d6a2b59b917b.tar.gz
gentoo-565028012e2de5f89adf918975a5d6a2b59b917b.tar.bz2
gentoo-565028012e2de5f89adf918975a5d6a2b59b917b.zip
dev-python/qtconsole: Bump to 5.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/Manifest1
-rw-r--r--dev-python/qtconsole/qtconsole-5.0.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index 2cf66dd3157b..32bb8babb4c6 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1,2 +1,3 @@
DIST qtconsole-4.7.6.tar.gz 424919 BLAKE2B d973b3b94dfad1b38603695e22927bcdcb8a4f2db9f4a638d5fe6a83c24061153dbaa36c26e632708953af32a015af1d40ecbf175dd5314a3b954b15a6625cc0 SHA512 e4e12eb90533e922786b5b6517fba5d9c4dfedf00547f1403c8cd65fb464f5c1a13517df69924e4428e9a8a811dfc359a7768fbaa90adbe02d79cba9a5aa852e
DIST qtconsole-5.0.1.tar.gz 424682 BLAKE2B 46f2cdea799786d7b2e9385a5b73ac397925eef9c2403f4d9ebd4ce89241cc1ca6ec494450759db4e017c16abc525505dacaa7452018379da5343c2b1cf24f86 SHA512 4fa7629c68ab7554c20bd8ef885bf4073d64d4c211a0d9035faaa7e4122bd5d182fb97773c8a41f215f9e299309ace591081a0673370b55c796b241211bb4ccc
+DIST qtconsole-5.0.2.tar.gz 428499 BLAKE2B 42d71e1a1909f8e07705fd5e7e64194d865b70cc67377ba631bb75fb8678faea4d8dddce90a2e84c0898fa074a88b655290bcf9ee1f9aebb39f91d2370908dbf SHA512 b74711c0444b74efc2fc31c631e6a87cfc05045d8ae9eb8253a9fcd1c82a1ecb688cbe50dc2f3dd4dc5d47c6e2b4fa027ac22e77b7ac37e1ed3fa0a9d2b677bb
diff --git a/dev-python/qtconsole/qtconsole-5.0.2.ebuild b/dev-python/qtconsole/qtconsole-5.0.2.ebuild
new file mode 100644
index 000000000000..9fea2d480c04
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+BDEPEND="
+ test? (
+ dev-python/QtPy[${PYTHON_USEDEP},svg,testlib]
+ )
+"
+# required by the tests that are removed:
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/pytest-qt[${PYTHON_USEDEP}]
+
+PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+src_prepare() {
+ # TODO: these tests require virtx; however, running under virtx
+ # causes pytest to segv on exit (even though tests pass)
+ rm qtconsole/tests/test_00_console_widget.py || die
+ distutils-r1_src_prepare
+}