summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-21 16:02:32 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-21 16:21:07 +0300
commit3a2d7b77cfcb2cbf20018eabab2ac553e71349d9 (patch)
treec1bec0646ff6f23dce6b0cef4638b7c86ba68e51 /dev-python/rdflib
parentdev-python/berkeleydb: initial import (NIH dep for dev-python/rdflib) (diff)
downloadgentoo-3a2d7b77cfcb2cbf20018eabab2ac553e71349d9.tar.gz
gentoo-3a2d7b77cfcb2cbf20018eabab2ac553e71349d9.tar.bz2
gentoo-3a2d7b77cfcb2cbf20018eabab2ac553e71349d9.zip
dev-python/rdflib: add 6.0.1, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/Manifest1
-rw-r--r--dev-python/rdflib/rdflib-6.0.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/rdflib/Manifest b/dev-python/rdflib/Manifest
index 3f0092e6d69a..edf5a67e38bc 100644
--- a/dev-python/rdflib/Manifest
+++ b/dev-python/rdflib/Manifest
@@ -1 +1,2 @@
DIST rdflib-5.0.0.tar.gz 818586 BLAKE2B d0046590b00211ccb4f0f586dc829c061a5f426b1cefed44a63d21d46396354b9012dbe0a63c8f9de138b25ca7d73ba624c49da6fb305ececd983c62c917fd8a SHA512 ba98ab6a7bb9d993d11c559a739761f297282eb9307f3e333db8dd1c6b365b408a59b701d823bef9be774a59b3f44f64c9444e3bb0115c0c549cb00945385dab
+DIST rdflib-6.0.1.tar.gz 1245483 BLAKE2B fd1c9837c25c8110bb44bd280803ec987ba865f8fea8187a1fca6173786deea65f462cf9f55f3c3c69d4fc18b01d37fc77b7b425e618c7b2e80324d7f5531f3e SHA512 d78c61a949a9c88297368820de386d289ef1722f5b2c4dad25a453c6bc9919fb98be23e682f739de6485f81746a1c338e4045c24ca058ed0b2848b81c0d34f52
diff --git a/dev-python/rdflib/rdflib-6.0.1.ebuild b/dev-python/rdflib/rdflib-6.0.1.ebuild
new file mode 100644
index 000000000000..35e96add88bd
--- /dev/null
+++ b/dev-python/rdflib/rdflib-6.0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite?,threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 optfeature
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib https://pypi.org/project/rdflib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples sqlite"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/berkeleydb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install nose
+
+python_prepare_all() {
+ # these tests require internet access
+ sed -e '/doctest/d' -i setup.cfg || die
+ rm test/{test_sparql_service.py,test_graph.py,jsonld/test_onedotone.py} || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ optfeature "support for sys-libs/db (Berkeley DB for MySQL)" dev-python/berkeleydb
+}