summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-27 07:09:37 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-27 07:56:27 +0200
commitdc7d8ebaf371d51d0528b925d8932963da4f7ad6 (patch)
treeaa08b643b38f958484569f007a701cd123aa3b5c /dev-python/readthedocs-sphinx-ext
parentdev-python/botocore: Update the live ebuild (diff)
downloadgentoo-dc7d8ebaf371d51d0528b925d8932963da4f7ad6.tar.gz
gentoo-dc7d8ebaf371d51d0528b925d8932963da4f7ad6.tar.bz2
gentoo-dc7d8ebaf371d51d0528b925d8932963da4f7ad6.zip
dev-python/readthedocs-sphinx-ext: Bump to 2.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/readthedocs-sphinx-ext')
-rw-r--r--dev-python/readthedocs-sphinx-ext/Manifest1
-rw-r--r--dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/readthedocs-sphinx-ext/Manifest b/dev-python/readthedocs-sphinx-ext/Manifest
index d451846291ee..64de04bd40af 100644
--- a/dev-python/readthedocs-sphinx-ext/Manifest
+++ b/dev-python/readthedocs-sphinx-ext/Manifest
@@ -1 +1,2 @@
DIST readthedocs-sphinx-ext-2.2.2.tar.gz 12106 BLAKE2B 4b9785c6b36ea66a7910d544b3acde9accc676e18b6c1e37b9285f6e095371bd7baf19b912b604596e92c89ad935c37263b2c977c66265e7697f18d399fd3006 SHA512 333e2068a92287821991e4e96b397e0d2b62f5080b65aff8f31b8828a7e930b038fb5ee176e20622e1a78c966c5d4cf84dfead832f4cbe1e68f2b0a0260009f7
+DIST readthedocs-sphinx-ext-2.2.3.tar.gz 12176 BLAKE2B 9467e3d08baa15fe64ce0a718e922e4f8dc6c0bd76fd8a53f4bae66114bbd043bbcca71a2b7b152a162d7ca89b102668ccdc9ab9b0904e0caf2e0ff953fc489c SHA512 f8c9b2b62c73307906fc61a2dacc0c9079c1b81920718fbd2c60a45e22da7e581b9fa60aca83003081753603cb904187cae6075922a62616554c8fcc4c1d7991
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.3.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.3.ebuild
new file mode 100644
index 000000000000..00dffbb4b59c
--- /dev/null
+++ b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="
+ https://github.com/readthedocs/readthedocs-sphinx-ext/
+ https://pypi.org/project/readthedocs-sphinx-ext/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest