summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-03-15 16:05:52 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-03-15 16:05:52 +0100
commite341a6dd358671ff29f09ca8db0a2d197ef33af0 (patch)
tree79a42b35c27bc23b6908256405fecc5ab4a7198e /dev-python/redis-py-cluster
parentapp-crypt/mhash: arm arm64 ppc64 stable (bug 611476). (diff)
downloadgentoo-e341a6dd358671ff29f09ca8db0a2d197ef33af0.tar.gz
gentoo-e341a6dd358671ff29f09ca8db0a2d197ef33af0.tar.bz2
gentoo-e341a6dd358671ff29f09ca8db0a2d197ef33af0.zip
dev-python/redis-py-cluster: Initial version 1.3.4
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-python/redis-py-cluster')
-rw-r--r--dev-python/redis-py-cluster/Manifest1
-rw-r--r--dev-python/redis-py-cluster/metadata.xml12
-rw-r--r--dev-python/redis-py-cluster/redis-py-cluster-1.3.4.ebuild19
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/redis-py-cluster/Manifest b/dev-python/redis-py-cluster/Manifest
new file mode 100644
index 000000000000..ce6391917cae
--- /dev/null
+++ b/dev-python/redis-py-cluster/Manifest
@@ -0,0 +1 @@
+DIST redis-py-cluster-1.3.4.tar.gz 32842 SHA256 3189ddde3a04f86f4322026c45a159411bda8f84ababe2c8e8e1fbdcb025f358 SHA512 4119780da7c7633b30d3ea525de82ca44629470b37eb1cc9f7b000d0cf237cfd0265cd2de0c093f064a350172b82334bea12687c49737d11be46d4c670a3e873 WHIRLPOOL 50e4ac4f0ab6128a88a55b1da34735e4d9e5a1304218d78403d3fefcc65ab90beb96dfbc8f53d9dc19d6223d3659b474e449c5a8f42524aa089ce4caf2a00884
diff --git a/dev-python/redis-py-cluster/metadata.xml b/dev-python/redis-py-cluster/metadata.xml
new file mode 100644
index 000000000000..7c4016d59320
--- /dev/null
+++ b/dev-python/redis-py-cluster/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">redis-py-cluster</remote-id>
+ <remote-id type="github">grokzen/redis-py-cluster</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/redis-py-cluster/redis-py-cluster-1.3.4.ebuild b/dev-python/redis-py-cluster/redis-py-cluster-1.3.4.ebuild
new file mode 100644
index 000000000000..ca25dacb34c3
--- /dev/null
+++ b/dev-python/redis-py-cluster/redis-py-cluster-1.3.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python cluster client for the official redis cluster"
+HOMEPAGE="https://github.com/Grokzen/redis-py-cluster"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-python/redis-py-2.10.2[${PYTHON_USEDEP}]"