summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-03-28 12:09:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-03-29 16:27:52 +0100
commitb989b71fe86b2c45aa6b58d4853d7d6d589bda26 (patch)
tree72868a7aa5eaf19fc2156692eab75333ac4ee5f2 /dev-python/respx
parentdev-libs/libtsm: drop 4.0.2 (diff)
downloadgentoo-b989b71fe86b2c45aa6b58d4853d7d6d589bda26.tar.gz
gentoo-b989b71fe86b2c45aa6b58d4853d7d6d589bda26.tar.bz2
gentoo-b989b71fe86b2c45aa6b58d4853d7d6d589bda26.zip
dev-python/respx: new package, add 0.21.1
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/respx')
-rw-r--r--dev-python/respx/Manifest1
-rw-r--r--dev-python/respx/metadata.xml20
-rw-r--r--dev-python/respx/respx-0.21.1.ebuild43
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/respx/Manifest b/dev-python/respx/Manifest
new file mode 100644
index 000000000000..899bbf1b2a9f
--- /dev/null
+++ b/dev-python/respx/Manifest
@@ -0,0 +1 @@
+DIST respx-0.21.1.gh.tar.gz 432341 BLAKE2B b375e8bc9370e13855197487e1e8139cf3fede0f03d7ad034ef2c78bce5ad95d3cb8cc7440c2566d188a98a52d0068c13288c7d4ec802e04d2f269a64e1ce326 SHA512 156f34f4635012230b68812f24978136f37f96dc0cf0ea9e80ed2d6a3e0639eb7591ed34933f75d5cda32993852aa034b22389af0fed341ab4ad1002482f2e9c
diff --git a/dev-python/respx/metadata.xml b/dev-python/respx/metadata.xml
new file mode 100644
index 000000000000..75a5ff3e72ad
--- /dev/null
+++ b/dev-python/respx/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>parona@protonmail.com</email>
+ <name>Alfred Wingate</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">respx</remote-id>
+ <remote-id type="github">lundberg/respx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/respx/respx-0.21.1.ebuild b/dev-python/respx/respx-0.21.1.ebuild
new file mode 100644
index 000000000000..398d107c282b
--- /dev/null
+++ b/dev-python/respx/respx-0.21.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock HTTPX with awesome request patterns and response side effects"
+HOMEPAGE="
+ https://lundberg.github.io/respx/
+ https://pypi.org/project/respx/
+ https://github.com/lundberg/respx/
+"
+# no tests in pypi sdist
+SRC_URI="
+ https://github.com/lundberg/respx/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpcore[${PYTHON_USEDEP}]
+ dev-python/starlette[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p 'no:*' -o addopts=
+}