summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-03-20 10:57:30 +0100
committerDavid Seifert <soap@gentoo.org>2020-03-20 10:57:30 +0100
commita5ef1eb188701d6924e2cfa2e48a2c8da995c4cc (patch)
tree357fbdd922e85412044348749c87c32dcec6d8dc /dev-python/restkit
parentdev-python/python-musicbrainz-ngs: Replace distutils-r1 EXAMPLES use (diff)
downloadgentoo-a5ef1eb188701d6924e2cfa2e48a2c8da995c4cc.tar.gz
gentoo-a5ef1eb188701d6924e2cfa2e48a2c8da995c4cc.tar.bz2
gentoo-a5ef1eb188701d6924e2cfa2e48a2c8da995c4cc.zip
dev-python/restkit: Replace distutils-r1 EXAMPLES use
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/restkit')
-rw-r--r--dev-python/restkit/restkit-4.2.2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/restkit/restkit-4.2.2.ebuild b/dev-python/restkit/restkit-4.2.2.ebuild
index 3f05d766057d..ba931dd23c91 100644
--- a/dev-python/restkit/restkit-4.2.2.ebuild
+++ b/dev-python/restkit/restkit-4.2.2.ebuild
@@ -46,6 +46,10 @@ python_test() {
python_install_all() {
use cli || rm "${D}"/usr/bin/restcli* || die
use doc && local HTML_DOCS=( doc/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
distutils-r1_python_install_all
}