summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2020-03-25 16:54:17 +0100
committerZac Medico <zmedico@gentoo.org>2020-04-03 23:27:46 -0700
commit55626f8c3e615b3b4d4740f077af0fadccbfb056 (patch)
tree399833a8214ad97ffb533d3b63d319293df0eb34 /dev-python/ropemode/ropemode-0.5.ebuild
parentdev-python/pylama: Bump to 7.7.1 (diff)
downloadgentoo-55626f8c3e615b3b4d4740f077af0fadccbfb056.tar.gz
gentoo-55626f8c3e615b3b4d4740f077af0fadccbfb056.tar.bz2
gentoo-55626f8c3e615b3b4d4740f077af0fadccbfb056.zip
dev-python/ropemode: Bump to 0.5
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/ropemode/ropemode-0.5.ebuild')
-rw-r--r--dev-python/ropemode/ropemode-0.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ropemode/ropemode-0.5.ebuild b/dev-python/ropemode/ropemode-0.5.ebuild
new file mode 100644
index 000000000000..2c3fb327d4cc
--- /dev/null
+++ b/dev-python/ropemode/ropemode-0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Currently (2020-03-23) rope is blocking
+# support for python 3.8.
+# For details see
+# https://github.com/python-rope/rope/pull/285
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A helper for using rope refactoring library in IDEs"
+HOMEPAGE="https://github.com/python-rope/ropemode https://pypi.org/project/ropemode/"
+SRC_URI="https://github.com/python-rope/ropemode/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# pypi releases don't include tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/rope[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" ropemodetest.py || die "tests failed with ${EPYTHON}"
+}