summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-17 11:35:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-17 11:35:51 +0200
commit1d952728c9d9f10e4703be43ef4c19b721ababa9 (patch)
tree0f05d62d13d39047f49e52ac5acbd806866adb11 /dev-python/rq
parentdev-java/openjdk: drop 11.0.22_p7 (diff)
downloadgentoo-1d952728c9d9f10e4703be43ef4c19b721ababa9.tar.gz
gentoo-1d952728c9d9f10e4703be43ef4c19b721ababa9.tar.bz2
gentoo-1d952728c9d9f10e4703be43ef4c19b721ababa9.zip
dev-python/rq: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.16.1.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index e03d130ba2cd..d5576c94eb41 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,2 +1 @@
-DIST rq-1.16.1.tar.gz 628089 BLAKE2B 74d57c34f338c8dfe14c921134253618253124fc34b69b78f0526a9c4d08b0d70ed50115658ee275f09b98ca48d7f5334032d81e0e9437184a0d3c4e782645fe SHA512 618f7833724b4bca5509132878d1bb28a25f99299a774709e839ff2b6771e27731330318070f6eb6c4aaced8167aec4ba02a89bf40285a9b16cd04e1935f7428
DIST rq-1.16.2.tar.gz 629881 BLAKE2B 69ac4ba43ea79ddf998bc9f7cf0fc5fa42acb0315dff663b1c924498ccfabdd37ac6d9613e128b838b9e1f45988632a337fb2fa50f5adcd1b69aa520b5ad33e2 SHA512 1c3162b1acffc9d11292fcbff7177267272a02e752b5839a4004b875bb5bb25af7e61f31041df438ef4e0e47152296c3a2711856c6a36d787848dcb766387d1a
diff --git a/dev-python/rq/rq-1.16.1.ebuild b/dev-python/rq/rq-1.16.1.ebuild
deleted file mode 100644
index 9ab9863d85e3..000000000000
--- a/dev-python/rq/rq-1.16.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{11..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Simple, lightweight library for creating and processing background jobs"
-HOMEPAGE="
- https://python-rq.org/
- https://github.com/rq/rq/
- https://pypi.org/project/rq/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- >=dev-python/click-5.0[${PYTHON_USEDEP}]
- >=dev-python/redis-4.5.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/sentry-sdk[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- # Spawn Redis itself for testing purposes
- # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
- # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- /usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the actual tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}