summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-15 05:48:07 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-15 05:48:07 +0200
commit3378184fc927a491fe405b663346bc6d99b009cd (patch)
tree4509c77d66e2114b5e92bd458392978648aaf59f /dev-python/scikit-build-core
parentdev-python/scikit-build-core: Remove old (diff)
downloadgentoo-3378184fc927a491fe405b663346bc6d99b009cd.tar.gz
gentoo-3378184fc927a491fe405b663346bc6d99b009cd.tar.bz2
gentoo-3378184fc927a491fe405b663346bc6d99b009cd.zip
dev-python/scikit-build-core: Bump to 0.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build-core')
-rw-r--r--dev-python/scikit-build-core/Manifest1
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.9.6.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index fbdfc5ec7f87..1805801eac3f 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1,2 +1,3 @@
DIST scikit_build_core-0.9.4.tar.gz 228198 BLAKE2B 86987ce34ed840d22a84a56fa0b62e8b6420f6f91763199945d5dfd0709ffb3b12778e996611cc652364637b8b8e0013cf39322fe322f1c2d3bbc22670c52876 SHA512 bc5252bf1f52e7fa0ea4d9e27d57fbf82a35e2061dfd8b8fbecc32b2da0ae88a2c3197bbece28f1285c1fb33ce91f27907bec093d76b937b382fa7dca072d0d9
DIST scikit_build_core-0.9.5.tar.gz 228404 BLAKE2B 6b3aa905a63b73147e1a760bf8e0265395f6e2b5cce2a24594ee384f6e8ad31d7d16e76e7666115e5a962f49c2f2a4c622a33ac5e3a11443cfc2ed50e0801589 SHA512 fade6192347ea9d3010a24de7c1b868aea14fa2028a064fe397db26e15437f74f3d9b017be940855d57db32cb867cfa9bab1902bc1f51f96589a38b9478d01bc
+DIST scikit_build_core-0.9.6.tar.gz 228743 BLAKE2B da5dff989ca053c9ee1abfff739d0b755bb14f9d810020e4b44ba5caad670dfe24ef99b4cb93a18ae162dca8fe21d6d09c4d692ff1406bfa3a64ca25c24aeddb SHA512 b2b1e9b4baefc360b26dfc0bbf0edef20d7b6681140ef9a413c565666869e67ddce2cdd3027f3de6af29b7ef76bd7eeb401c08f3803524706d0ace9106b63f65
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.9.6.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.9.6.ebuild
new file mode 100644
index 000000000000..729919e913ae
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.9.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# we always want [pyproject] extra
+RDEPEND="
+ app-alternatives/ninja
+ dev-build/cmake
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local _EPYTEST_DESELECT=(
+ # TODO / we don't package validate_pyproject anyway
+ tests/test_schema.py::test_compare_schemas
+ # setuptools now respects PEP 625
+ tests/test_setuptools_pep517.py::test_pep517_sdist
+ )
+ local EPYTEST_IGNORE=(
+ # needs unpackaged validate_pyproject
+ tests/test_schema.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p subprocess -m "not isolated and not network"
+}