summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-21 05:03:48 +0100
committerSam James <sam@gentoo.org>2022-09-21 05:05:01 +0100
commita5010cf3a2d735b2ba041401d3d9ea13839d295a (patch)
tree44a0a176c71fbf40d9e4364c97acecae52d19732 /dev-python/scipy
parentsys-devel/make: fix metadata indentation (diff)
downloadgentoo-a5010cf3a2d735b2ba041401d3d9ea13839d295a.tar.gz
gentoo-a5010cf3a2d735b2ba041401d3d9ea13839d295a.tar.bz2
gentoo-a5010cf3a2d735b2ba041401d3d9ea13839d295a.zip
dev-python/scipy: disable docs for live
Closes: https://bugs.gentoo.org/872122 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/scipy-1.9.9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/scipy/scipy-1.9.9999.ebuild b/dev-python/scipy/scipy-1.9.9999.ebuild
index 47dd4358d2c0..e2718fe21ca6 100644
--- a/dev-python/scipy/scipy-1.9.9999.ebuild
+++ b/dev-python/scipy/scipy-1.9.9999.ebuild
@@ -84,7 +84,7 @@ distutils_enable_tests pytest
src_unpack() {
default
- if use doc; then
+ if [[ ${PV} != *9999 ]] && use doc; then
unzip -qo "${DISTDIR}"/${PN}-html-${DOC_PV}.zip -d html || die
fi
}
@@ -96,9 +96,10 @@ python_test() {
}
python_install_all() {
- use doc && \
- local DOCS=( "${DISTDIR}"/${PN}-ref-${DOC_PV}.pdf ) \
+ if [[ ${PV} != *9999 ]] && use doc; then
+ local DOCS=( "${DISTDIR}"/${PN}-ref-${DOC_PV}.pdf )
local HTML_DOCS=( "${WORKDIR}"/html/. )
+ fi
distutils-r1_python_install_all
}