summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-16 16:48:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-16 16:58:46 +0200
commit1bd8e0d908713088afa0d856f437d0e96c7c387d (patch)
tree452f62ed5f9255a0dcd89ab7cd376170b799166a /dev-python/selenium
parentdev-libs/libgit2: Bump to 1.8.1 (diff)
downloadgentoo-1bd8e0d908713088afa0d856f437d0e96c7c387d.tar.gz
gentoo-1bd8e0d908713088afa0d856f437d0e96c7c387d.tar.bz2
gentoo-1bd8e0d908713088afa0d856f437d0e96c7c387d.zip
dev-python/selenium: Bump to 4.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/selenium')
-rw-r--r--dev-python/selenium/Manifest2
-rw-r--r--dev-python/selenium/selenium-4.21.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/selenium/Manifest b/dev-python/selenium/Manifest
index 4249970740be..97f880aef1cf 100644
--- a/dev-python/selenium/Manifest
+++ b/dev-python/selenium/Manifest
@@ -1,2 +1,4 @@
DIST selenium-4.20.0.tar.gz 9307193 BLAKE2B 26d0441039776ae0c524891ed89ce2b631b2d74b561403890081ba649e1d067b841610e53d468fc2aa622fea05affd997f580e63af44256eb33dffe17b65b619 SHA512 102ce43dd9878275a80fa5e8c59162952c9ab04173c3c35f543392b31df1d600f403ad7764af76513c81df8eef5781456bf6ef2027af6a93ad99d855ab384869
+DIST selenium-4.21.0.tar.gz 9238881 BLAKE2B 6aadfb383aabb730dd9a39dc526a7b109d640997b1ba5e486687c4e3f056a6dee624c88ed437b40c6e63689a533a5990e14e0d57afe2ed927bf9f3e4a1573266 SHA512 e5486a411aeaffb26be2f50a874c622bcd6d004cb821444c580ef5fc3e74fbc0575d00ced5f4e57b3bf75e0920eb835a423e6e8d8cf354c729d3036bfb170dec
DIST selenium-selenium-4.20.0.gh.tar.gz 77055043 BLAKE2B 3a146a41fcebe0abb0a83b914a66252f541ab712e606166c941c08781cca92315254d3be075a988044713544909134dc7a9203ac414ba7f7985173713779e810 SHA512 1a4ee0421c8ba02fc8217792fda26bb977524531bdaaf8cb56276decdddb13adc702bd20ac195c97a7182fdd27c3a88b92a901af38c6fd059c2421e422c82768
+DIST selenium-selenium-4.21.0.gh.tar.gz 77070811 BLAKE2B b9aacaf5f6091f49c4f0a6c7dca3fb5791297af8e1a8b6fa6b8e6d77fa5249d9b3c74d6c73a5aa9f443fefc3a613e0b6a12ced1f400d93c99a43b5614a6edda8 SHA512 15f25efc893fd57ef0ca21e3598c1ae976043fd8000275ff9bed117ff0c9e9c402ed1bc3fff119a511336b0e26343c6e36450b3ef49cad2dda3b1cea039ec6a7
diff --git a/dev-python/selenium/selenium-4.21.0.ebuild b/dev-python/selenium/selenium-4.21.0.ebuild
new file mode 100644
index 000000000000..e74259a73bf0
--- /dev/null
+++ b/dev-python/selenium/selenium-4.21.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+# upstream sometimes tags it as ${P}, sometimes as ${P}-python, sigh
+TEST_TAG=${P}
+TEST_P=selenium-${TEST_TAG}
+
+DESCRIPTION="Python language binding for Selenium Remote Control"
+HOMEPAGE="
+ https://www.seleniumhq.org/
+ https://github.com/SeleniumHQ/selenium/tree/trunk/py/
+ https://pypi.org/project/selenium/
+"
+SRC_URI+="
+ test? (
+ https://github.com/SeleniumHQ/selenium/archive/${TEST_TAG}.tar.gz
+ -> ${TEST_P}.gh.tar.gz
+ )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/certifi-2021.10.8[${PYTHON_USEDEP}]
+ <dev-python/trio-1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.17[${PYTHON_USEDEP}]
+ <dev-python/trio-websocket-1[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9[${PYTHON_USEDEP}]
+ <dev-python/typing-extensions-5[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.9[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO: we may need extra setup or deps
+ test/selenium
+
+ # expects vanilla certifi
+ test/unit/selenium/webdriver/remote/remote_connection_tests.py::test_get_connection_manager_for_certs_and_timeout
+ )
+
+ cd "${WORKDIR}/${TEST_P}/py" || die
+ rm -rf selenium || die
+ # https://github.com/SeleniumHQ/selenium/blob/selenium-4.8.2-python/py/test/runner/run_pytest.py#L20-L24
+ # seriously?
+ epytest -o "python_files=*_tests.py test_*.py"
+}