summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 09:52:43 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 09:52:43 +0100
commit29b1ccee88ac96ee8d31329982f8fc26e78800f0 (patch)
treef16e452c529eab4a4fcd18ba94381bbf63f67bc3 /dev-python/semantic_version
parentdev-python/semantic_version: Mark x86 stable under ALLARCHES (diff)
downloadgentoo-29b1ccee88ac96ee8d31329982f8fc26e78800f0.tar.gz
gentoo-29b1ccee88ac96ee8d31329982f8fc26e78800f0.tar.bz2
gentoo-29b1ccee88ac96ee8d31329982f8fc26e78800f0.zip
dev-python/semantic_version: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/semantic_version')
-rw-r--r--dev-python/semantic_version/Manifest2
-rw-r--r--dev-python/semantic_version/semantic_version-2.6.0-r1.ebuild26
-rw-r--r--dev-python/semantic_version/semantic_version-2.6.0-r2.ebuild39
-rw-r--r--dev-python/semantic_version/semantic_version-2.6.0.ebuild23
4 files changed, 0 insertions, 90 deletions
diff --git a/dev-python/semantic_version/Manifest b/dev-python/semantic_version/Manifest
index 476e9e6d1047..073d02691b2d 100644
--- a/dev-python/semantic_version/Manifest
+++ b/dev-python/semantic_version/Manifest
@@ -1,3 +1 @@
-DIST semantic_version-2.6.0-1.tar.gz 31678 BLAKE2B 030189762a11559fee8527bf1735fbc596caa4e641b61fdce90e1c1cd6e7a3e957aad13dabb2d90ade2f91028c5a7f35c39c1a9d47afd76d3274c2b755f2b14a SHA512 18db9279c2728565b13362c54bedbf569f0878cbe6bb58e631d87ffe7cff7d9131a30a2592cbf511091c03e854851159bbb298fe7469f53e8a2d92cf26ab4d0b
-DIST semantic_version-2.6.0.tar.gz 13919 BLAKE2B 811b3bfdb8ffc4cf8358400da1f18d5d0851c2999ff7df73fc0380e508b4039ce760dcf9d438bbb5d112ff1754b1855b3e062652b28be7f607516d8d017b9830 SHA512 805449e7219aaa59d28cc267c27a6abab5cbbbfd52c72d66f24bcace39c9f864e4ed944a3dc614e14a700a5bc92272fa6420312f3169b01a4cfd9ddf3ffb42d6
DIST semantic_version-2.8.2.tar.gz 49243 BLAKE2B 73c66696b2fd6e30dc74bba6f1d4d84d71bf470f8ecd2ab93b4225f573bb0575f797b573d8fa6605ff35636de713a8f69522a2719949cf0bfebd0791ab5bae99 SHA512 f54ad2bb2e8392e154718c3dff8e7a7fa7663d7df0ab4b196444e0ad22440fe9d9a3abe9043824c0e0121f9051121b8c9d67f76a615aa5348c321e217b3a5dcd
diff --git a/dev-python/semantic_version/semantic_version-2.6.0-r1.ebuild b/dev-python/semantic_version/semantic_version-2.6.0-r1.ebuild
deleted file mode 100644
index 0882933a69a1..000000000000
--- a/dev-python/semantic_version/semantic_version-2.6.0-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library providing a few tools handling SemVer in Python"
-HOMEPAGE="https://pypi.org/project/semantic_version/"
-SRC_URI="https://github.com/rbarrois/python-semanticversion/archive/v${PV}.tar.gz -> ${P}-1.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/django[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/python-${P/_/}
-
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/semantic_version/semantic_version-2.6.0-r2.ebuild b/dev-python/semantic_version/semantic_version-2.6.0-r2.ebuild
deleted file mode 100644
index cd93fd604422..000000000000
--- a/dev-python/semantic_version/semantic_version-2.6.0-r2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library providing a few tools handling SemVer in Python"
-HOMEPAGE="https://pypi.org/project/semantic_version/"
-SRC_URI="https://github.com/rbarrois/python-semanticversion/archive/v${PV}.tar.gz -> ${P}-1.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}/python-${P/_/}"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # The django test hangs
- py.test --ignore tests/test_django.py\
- || die "tests failed with ${EPYTHON}"
-}
diff --git a/dev-python/semantic_version/semantic_version-2.6.0.ebuild b/dev-python/semantic_version/semantic_version-2.6.0.ebuild
deleted file mode 100644
index d8ebb37e49af..000000000000
--- a/dev-python/semantic_version/semantic_version-2.6.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library providing a few tools handling SemVer in Python."
-HOMEPAGE="https://pypi.org/project/semantic_version/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-python_test() {
- esetup.py test
-}