summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-07 06:42:01 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-07 07:09:35 +0200
commitd7c97ebbfce54f236d4ea5e433a41769474ab86e (patch)
treedbbc89d58f9b806b6532e2cc5af8be0dddc99a8f /dev-python/sexpdata
parentapp-portage/emlop: add missing dies (diff)
downloadgentoo-d7c97ebbfce54f236d4ea5e433a41769474ab86e.tar.gz
gentoo-d7c97ebbfce54f236d4ea5e433a41769474ab86e.tar.bz2
gentoo-d7c97ebbfce54f236d4ea5e433a41769474ab86e.zip
dev-python/sexpdata: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sexpdata')
-rw-r--r--dev-python/sexpdata/Manifest1
-rw-r--r--dev-python/sexpdata/sexpdata-1.0.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/sexpdata/Manifest b/dev-python/sexpdata/Manifest
index f073d38fc5bb..3b9a667c8a58 100644
--- a/dev-python/sexpdata/Manifest
+++ b/dev-python/sexpdata/Manifest
@@ -1 +1,2 @@
DIST sexpdata-1.0.0.gh.tar.gz 16540 BLAKE2B 6babe7b098d9e66bc9cbd6c8a8e91b8d9743ee93ca6745f626421ecab498fc70a02e16e5e3973b97b886feaf4042489f6903736c43f4264252122e1f190b9fc4 SHA512 1ef72d6441907ea3eae00b6d89344281930ac3ad82aee429fa45d2f876aef890019b0bae0241d1670d8f9842dd47a1be76d33dd510b38b09b904334a3924bb56
+DIST sexpdata-1.0.1.gh.tar.gz 17298 BLAKE2B 41132d8d2af06efdae024cbb8e05e9fa4fcb03ffb0af5f1b04df2fae8ed3a5bd8a45f93951cf575edf3facb0f9867a6e78d82ab166f0ec89df4a13b0827d7213 SHA512 e945eeec3743d92a76748c6fe22ca510ec5df6a3f2249a0d8020ae84854c50940add39437c680d3e44aafee7d9bb442db875b46afd290bfb6e8d31e16c6da9da
diff --git a/dev-python/sexpdata/sexpdata-1.0.1.ebuild b/dev-python/sexpdata/sexpdata-1.0.1.ebuild
new file mode 100644
index 000000000000..0701002c9691
--- /dev/null
+++ b/dev-python/sexpdata/sexpdata-1.0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="a simple S-expression parser/serializer"
+HOMEPAGE="
+ https://github.com/jd-boyd/sexpdata/
+ https://pypi.org/project/sexpdata/
+"
+SRC_URI="
+ https://github.com/jd-boyd/sexpdata/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+distutils_enable_tests pytest