summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-04-06 11:47:50 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-04-06 11:48:49 -0700
commit43119765edf5f9a72b4e8d7931521ed8ad105d25 (patch)
treea0de10c49a2b11e98d0e1c0827e14160d505dccf /dev-python/slackclient/slackclient-2.5.0.ebuild
parentsys-power/bbswitch-0.8-r3: kernel 5.6 support; $CC fixes. (diff)
downloadgentoo-43119765edf5f9a72b4e8d7931521ed8ad105d25.tar.gz
gentoo-43119765edf5f9a72b4e8d7931521ed8ad105d25.tar.bz2
gentoo-43119765edf5f9a72b4e8d7931521ed8ad105d25.zip
dev-python/slackclient: bump & add self as maintainer
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-python/slackclient/slackclient-2.5.0.ebuild')
-rw-r--r--dev-python/slackclient/slackclient-2.5.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/slackclient/slackclient-2.5.0.ebuild b/dev-python/slackclient/slackclient-2.5.0.ebuild
new file mode 100644
index 000000000000..c5f5e7eec92b
--- /dev/null
+++ b/dev-python/slackclient/slackclient-2.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Client for Slack supporting the Slack Web and Real Time Messaging API"
+HOMEPAGE="https://github.com/slackapi/python-slackclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # upstream does not include tests in the package tarball!
+
+RDEPEND="
+ >dev-python/aiohttp-3.5.2[${PYTHON_USEDEP}]
+ >dev-python/aiodns-1.0.0[${PYTHON_USEDEP}]
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"