summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-21 08:52:30 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-21 09:54:37 +0100
commitb834abfba1e716441df5569295ee8565ca155e87 (patch)
tree8b99be7792c7ec5cd351ee375141454c70cabb03 /dev-python/slixmpp
parentsci-mathematics/z3: Bump to 4.8.15 (diff)
downloadgentoo-b834abfba1e716441df5569295ee8565ca155e87.tar.gz
gentoo-b834abfba1e716441df5569295ee8565ca155e87.tar.bz2
gentoo-b834abfba1e716441df5569295ee8565ca155e87.zip
dev-python/slixmpp: Bump to 1.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/slixmpp')
-rw-r--r--dev-python/slixmpp/Manifest1
-rw-r--r--dev-python/slixmpp/slixmpp-1.8.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
index 9f186289bf7f..a816fce8cb4e 100644
--- a/dev-python/slixmpp/Manifest
+++ b/dev-python/slixmpp/Manifest
@@ -1,2 +1,3 @@
DIST slixmpp-1.7.1.tar.gz 931753 BLAKE2B 3de14be36353bc5f5f2cfbe002c44c5e843a7b36fa31a9dd315e363fc67e36d080df0dc70d82e65c6802c41377c2e98f56ff4e23cc5e9a92165c3d3b7565493f SHA512 5a59fcbb901e6f4456049f1ec2bbf781b1ec7c5a3ad4b66216d4c5daffa7f0606f74b941647fe2b53e6c8cdc476371305c7b7a2ca24d21450e19548f888be3b1
DIST slixmpp-1.8.0.1.tar.gz 532519 BLAKE2B c4cda06d1d16ef92404263a90a6abbba46e526b4f9edc54228757b73c9faa0f04e9340ea80b5f0491017bad04094512bd25fe04fc095742b639cecba73db058b SHA512 0bfa39f126f2154702e160117b619f41319362723226ebf0ed4b803aafef0302d4df9d9a4cff5fd890507a10ac7424a07cc3bece519451bd56be400998dc0178
+DIST slixmpp-1.8.1.tar.gz 532622 BLAKE2B d0c12c240c8a14df0a0765f8bac02eb545951a0b9749ec9569d651caa3457af1a71f1c6b3a10db879fe25648b1c3c456b78e48042a83124b0a8d4d35df60134d SHA512 13b355592d564b7e211e6007fa19099e619480d0a87332b68163115852840ad2f0c70063b4260fc88d4da67e13ea97c88972fc05999c1870256b0de0257409f9
diff --git a/dev-python/slixmpp/slixmpp-1.8.1.ebuild b/dev-python/slixmpp/slixmpp-1.8.1.ebuild
new file mode 100644
index 000000000000..1a7f67fcb5c6
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.8.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://lab.louiz.org/poezio/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ net-dns/libidn
+"
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest