summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/soappy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/soappy')
-rw-r--r--dev-python/soappy/Manifest3
-rw-r--r--dev-python/soappy/files/soappy-0.12.0-python-2.5-compat.patch68
-rw-r--r--dev-python/soappy/metadata.xml8
-rw-r--r--dev-python/soappy/soappy-0.12.20.ebuild42
-rw-r--r--dev-python/soappy/soappy-0.12.22.ebuild43
-rw-r--r--dev-python/soappy/soappy-0.12.5-r2.ebuild42
6 files changed, 206 insertions, 0 deletions
diff --git a/dev-python/soappy/Manifest b/dev-python/soappy/Manifest
new file mode 100644
index 000000000000..51dc30ce7457
--- /dev/null
+++ b/dev-python/soappy/Manifest
@@ -0,0 +1,3 @@
+DIST SOAPpy-0.12.20.zip 172192 SHA256 ed42ee76a1f1c6ce767296d67ef482059e32eb66cdcbc3ed6b6b9c3922444277 SHA512 f4140327295d0d301093aa13ae35ebc1faabd4aafc259b9866072d57da82bc7742fc852904bddc978792f97cb577afc97e35d47f350c9e5f1426a4928aeb8351 WHIRLPOOL a5568ba25f9e3b22310f447c35f612038f32fc60b20b28aa292b4db7239bb9247772a1192eb2ec1e2f51429c1c1f99dc54ac37b6aae9b4d1418841ae07072f28
+DIST SOAPpy-0.12.22.zip 172855 SHA256 e70845906bb625144ae6a8df4534d66d84431ff8e21835d7b401ec6d8eb447a5 SHA512 d75d0bf8e88c8ecae57f51a201f9ab6f24fc41856ee2093e7e2e73e5d8618c9a766a69140df28a24b6d8493b53555c09502684c6d2fd78e90a3c53bba52f388b WHIRLPOOL 8ac248d98f9da45bcbdd9a9bf55bb7fd4b83de097ca641453c7cf18833c4dc5cd5b4e09e3e5bce3cf4be0c6c09e4e10638aa6a5244afc6cc791996b63a1c3d5e
+DIST SOAPpy-0.12.5.tar.gz 153106 SHA256 8d8e3bf304f5669432d58cc0c2870766096ef5e4e89889aa1bce6d7a68994ef7 SHA512 cee6a4556beac20c68c3bcfe14454b9911655f78987c6fe9a6ce5f08090ded7bbf71a067d848368cf20101ff374e0992f34428b48b9a451eb67a925e92a149a9 WHIRLPOOL 2ba4b0a7cacbf132ca824a1703c811ecba19f852c88b9ac994feba10cce5e9f98769f284cc080c4a6dfd1cba3db7c2d1d69a258bdd3c3f1aeadb11b4cbfbc137
diff --git a/dev-python/soappy/files/soappy-0.12.0-python-2.5-compat.patch b/dev-python/soappy/files/soappy-0.12.0-python-2.5-compat.patch
new file mode 100644
index 000000000000..297bcc4b0c23
--- /dev/null
+++ b/dev-python/soappy/files/soappy-0.12.0-python-2.5-compat.patch
@@ -0,0 +1,68 @@
+diff -urN SOAPpy.orig/Client.py SOAPpy/Client.py
+--- SOAPpy.orig/Client.py 2005-02-21 21:27:09.000000000 +0100
++++ SOAPpy/Client.py 2007-01-07 15:46:13.000000000 +0100
+@@ -40,11 +40,11 @@
+ ################################################################################
+ """
+
++from __future__ import nested_scopes
++
+ ident = '$Id: Client.py,v 1.27 2005/02/21 20:27:09 warnes Exp $'
+ from version import __version__
+
+-from __future__ import nested_scopes
+-
+ #import xml.sax
+ import urllib
+ from types import *
+diff -urN SOAPpy.orig/GSIServer.py SOAPpy/GSIServer.py
+--- SOAPpy.orig/GSIServer.py 2005-02-15 17:32:22.000000000 +0100
++++ SOAPpy/GSIServer.py 2007-01-07 15:46:38.000000000 +0100
+@@ -43,11 +43,11 @@
+ ################################################################################
+ """
+
++from __future__ import nested_scopes
++
+ ident = '$Id: GSIServer.py,v 1.5 2005/02/15 16:32:22 warnes Exp $'
+ from version import __version__
+
+-from __future__ import nested_scopes
+-
+ #import xml.sax
+ import re
+ import socket
+diff -urN SOAPpy.orig/Server.py SOAPpy/Server.py
+--- SOAPpy.orig/Server.py 2005-02-15 17:32:22.000000000 +0100
++++ SOAPpy/Server.py 2007-01-07 15:46:59.000000000 +0100
+@@ -40,11 +40,11 @@
+ ################################################################################
+ """
+
++from __future__ import nested_scopes
++
+ ident = '$Id: Server.py,v 1.21 2005/02/15 16:32:22 warnes Exp $'
+ from version import __version__
+
+-from __future__ import nested_scopes
+-
+ #import xml.sax
+ import re
+ import socket
+diff -urN SOAPpy.orig/Types.py SOAPpy/Types.py
+--- SOAPpy.orig/Types.py 2005-02-22 05:29:43.000000000 +0100
++++ SOAPpy/Types.py 2007-01-07 15:47:17.000000000 +0100
+@@ -33,11 +33,11 @@
+ ################################################################################
+ """
+
++from __future__ import nested_scopes
++
+ ident = '$Id: Types.py,v 1.19 2005/02/22 04:29:43 warnes Exp $'
+ from version import __version__
+
+-from __future__ import nested_scopes
+-
+ import UserList
+ import base64
+ import cgi
diff --git a/dev-python/soappy/metadata.xml b/dev-python/soappy/metadata.xml
new file mode 100644
index 000000000000..8ffda60e16d0
--- /dev/null
+++ b/dev-python/soappy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">SOAPpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/soappy/soappy-0.12.20.ebuild b/dev-python/soappy/soappy-0.12.20.ebuild
new file mode 100644
index 000000000000..60df7df9ab17
--- /dev/null
+++ b/dev-python/soappy/soappy-0.12.20.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl?,xml"
+
+inherit distutils-r1
+
+MY_PN="SOAPpy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SOAP Services for Python"
+HOMEPAGE="http://pywebsvcs.sourceforge.net/ http://pypi.python.org/pypi/SOAPpy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x64-macos ~x86-macos"
+IUSE="examples ssl"
+
+RDEPEND="dev-python/fpconst[${PYTHON_USEDEP}]
+ dev-python/wstools[${PYTHON_USEDEP}]
+ ssl? ( dev-python/m2crypto[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES.txt README.txt docs/. )
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r bid contrib tools validate
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/soappy/soappy-0.12.22.ebuild b/dev-python/soappy/soappy-0.12.22.ebuild
new file mode 100644
index 000000000000..530a3659f39b
--- /dev/null
+++ b/dev-python/soappy/soappy-0.12.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl?,xml"
+
+inherit distutils-r1
+
+MY_PN="SOAPpy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SOAP Services for Python"
+HOMEPAGE="http://pywebsvcs.sourceforge.net/ http://pypi.python.org/pypi/SOAPpy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86"
+
+IUSE="examples ssl"
+
+RDEPEND="dev-python/wstools[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ ssl? ( dev-python/m2crypto[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES.txt README.txt docs/. )
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r bid contrib tools validate
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/soappy/soappy-0.12.5-r2.ebuild b/dev-python/soappy/soappy-0.12.5-r2.ebuild
new file mode 100644
index 000000000000..f504dd50e283
--- /dev/null
+++ b/dev-python/soappy/soappy-0.12.5-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl?,xml"
+
+inherit distutils-r1
+
+MY_PN="SOAPpy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SOAP Services for Python"
+HOMEPAGE="http://pywebsvcs.sourceforge.net/ http://pypi.python.org/pypi/SOAPpy"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x64-macos ~x86-macos"
+IUSE="examples ssl"
+
+RDEPEND="dev-python/fpconst[${PYTHON_USEDEP}]
+ dev-python/wstools[${PYTHON_USEDEP}]
+ ssl? ( dev-python/m2crypto[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES.txt README.txt docs/. )
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r bid contrib tools validate
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}